Support » Plugin: WooCommerce » Tax not working (tax always equals 0)

  • Resolved Haap

    (@haap)


    As a follow-up to this thread.

    We have setup Woocommerce (2.3.8) on a wordpress (4.2.2) site at projecth.nl.

    When adding taxes, the site does not calculate taxes at all. It always shows tax at 0.

    The following settings are used:

    • Activate tax (selected)
    • Show prices excluding tax
    • Tax based upon shop address
    • Shipping cost tax: Standard rates
    • show prices in shop excluding tax
    • show prices excluding tax during checkout
    • show taxes as one total

    Screenshot (sorry for the Dutch language

    Tax rates are applied at 21% for all countries (it is based on shop address anyway). another screenshot

    The product is “taxable” at the standard tax rate: see this screenshot.

    I have tried changing every setting, uninstalling and re-installing almost everything (including wordpress and woocommerce), cleared all tax settings (via woocommerce system tools), cleared the entire store, et cetera. All at no avail.

    Is this a bug to new sites, or am I somehow missing something? Thanks in advance for your help.

    Haap

    https://wordpress.org/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 42 total)
  • kevin13952

    (@kevin13952)

    I’m also having the same problem. I have tried every possible setting and combination of settings and I too can’t get taxes to calculate.

    I’ve created a fictitious customer and given them a billing and shipping address. I then login as that customer and add an item to my cart and go to the view cart screen. It always shows tax as ZERO dollars.

    My settings are the same as yours listed above except I am basing taxes on the default shipping address. I use an asterick for country and state. I have a 10.0000 percentage tax rate and I don’t compound the taxes or tax on shipping.

    I seriously need to get this issue fixed or I will have to abandon woocommerce and go to another shopping cart altogether.

    rocketboxdesign

    (@rocketboxdesign)

    I have the exact same problem. I’ve checked and triple checked everything. Tax is ALWAYS calculated at £0.

    I’ve even tried rolling back to previous versions of Woocommerce. What on earth os going here this is a really vital thing to get wrong?!? I am pleased to see I’m not just the only one though.

    Haap

    (@haap)

    Thanks all, for confirming that it’s not just me. I’ve filed an issue in/on/at GitHub. If anyone has a solution or also has this problem, please let me/us know.

    bluantinoo

    (@bluantinoo)

    I have the same problem.
    But along with another one: I can’t save tax rates.

    I can create “aliquotes”, but I can’t insert tax rates in each alquote.
    I fill the row to enter a taxation rate (it does not matter if I use a country codes or not), click save button, and the row is no more there.

    I’ve looked in database, in “PREFIX_woocommerce_tax_rates” table, I see rates are saved without the “tax_rate_class” field. I’ve tried to enter the correct class manually, and like that the tax row is shown in backend, but it’s not applied to any of my product.

    I’m really stuck on this!

    bluantinoo

    (@bluantinoo)

    I solved deactivating Woocommerce, uploading a new one and reactivating.
    Weird.

    Haap

    (@haap)

    Thanks bluantinoo for sharing your fix! Do I understand it correctly that you did not uninstall WooCommerce?

    I tried deactivating WooCommerce and uploading WC 2.3.8. I just downloaded. That did not work.

    I also deinstalled WooCommerce (including all files), and installed a new version by uploading it. That did also not work, unfortunately.

    Same problem here… What do I have to put as “tax_rate_class” db value? If i put a value it disappear from dashboard

    I’m having the same issue as everyone else. I have the Tax settings as stated in the videos however when I add a taxable product it never applies the tax.

    I have the same problem
    anything I enter in ZIP/Postcode and City, disappears after saving

    Same problem. Using WP 4.2.2 and Woocommerce 2.3.11. Looks noting happen with the BTW / Tax calculation.

    Guys this is also not working for me, and driving me batty!

    Urgent patch please!!

    Guys, there’s comfort in numbers but too many to be able to help individually. Everyone has a different setup and maybe a different cause even if the outcome is the same.

    Tax not calculating checklist:

    Cache – Deactivate cache until your site is completely debugged and development is finished. Put the cart and checkout pages on the cache plugin’s do-not-cache list. Look at the bottom of the cart and checkout pages markup to ensure the are not being cached.

    Database – Some installs don’t have a wp_tax_rate_locations table, don’t know why. Add the table with the following mySql script, use it in phpMyAdmin:
    http://pastebin.com/rVGcPpZ5
    There are several recent threads on here about that. The table can be empty but it must exist.

    Update – Most users keep WordPress and WooCommerce up-to-date, but not their theme. So you have a combination of components not tested to work together. Ensure the theme is bang up-to-date. Take a backup before updating.

    Location – WooCommerce doesn’t know where the customer lives, so set Default customer address to Shop Base Address. The Shop Base address does not have a zip code, so ensure there is a line in the Standard Rates table to catch this any-zip-code location.

    Simplify – Deactivate all other plugins and switch to the default theme. If it still doesn’t work you probably have a corrupt install. Reinstall using fresh downloads. You may also need a fresh database. If it does work, reactivate components one-by-one to try to identify the one that is causing the conflict.

    New thread – If its still not working, as per forum guidelines, please start your own thread. Include the url to your site, what steps you have taken and screenshots of your WooCommerce General settings, Tax Options and Standard Rates setting screens.

    Last resort – get someone in:
    http://jobs.wordpress.net/

    For some of you guys, if after exhausted all options and you still can’t get your sales tax setting backup, you might want to try the tax setup service on https://www.woosalestax.com. They don’t charge you unless they can fix your problem. Good luck!

    Having the same problem, I tried everything, nothing helped. Frustrating!

    same problem here!

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘Tax not working (tax always equals 0)’ is closed to new replies.