Support » Plugin: WooCommerce » Tax gets applied to shipping even though disabled

  • Resolved pleazo

    (@pleazo)


    Hello,

    I am having an issue with shipping tax always getting charged at checkout. As I have some products I need to charge shipping tax on and some not (depending on where I ship the product to), I need this option. For example: If I ship to Germany, I need to charge tax only on the product but we don’t charge tax on shipping here. If I ship to the UK, I need to charge tax both on the product & shipping.

    I have done the following:
    1. Created a tax class named “EU VAT only rates” & unchecked the shipping boxes: https://snipboard.io/bdGzrv.jpg

    2. However, at checkout I am still being charged tax on shipping: https://snipboard.io/h1HqQ8.jpg (shipping shows .95 tax charged, but should be 0)

    Am I doing something wrong here in the settings?

    Best,
    Chris

    • This topic was modified 3 months, 1 week ago by pleazo.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support abwaita

    (@abwaita)

    Hi Chris!

    Kindly share with us a screenshot of the Standard Tax rates as well.

    Also, check your shipping tax class at WooCommerce → Settings → Taxes → Tax options > Shipping tax class. It might be using a different tax class than the EU VAT only rates.

    Thanks.

    Thread Starter pleazo

    (@pleazo)

    Hi @abwaita

    Here are the standard tax rates: https://snipboard.io/zNUlkD.jpg

    My shipping class looks like this: https://snipboard.io/ZjNkBn.jpg However I am not using any tax classes in my shipping setting, should I be?

    Best,
    Chris

    Plugin Support Joey – a11n

    (@jricketts4)

    Hi again @pleazo – can you also check within the Flat Rate settings to see if it’s still set to ‘Taxable’?

    If it is, can you try setting that to ‘None’ and checking again?

    If that still doesn’t work, can you also send us screenshots of the following?

    • the ‘Shipping’ tab of a product’s settings page
    • the ‘Flat Rate’ settings for this shipping zone
    Thread Starter pleazo

    (@pleazo)

    Hi @jricketts4

    Thanks for your response.

    The tax rate settings is always set to none. It’s coming from Dokan however these settings do not work. I tested it setting it to taxable and non table but it does not make any difference. Dokan even told me this. Their exact words “Currently, Dokan doesn’t allow vendors to make it taxable it’s possible only from the admin dashboard. We put a toggle option though for vendors to make it on and but it will not make any difference.”

    Here are the screenshots of the following:
    Shipping tab: https://snipboard.io/1KetdZ.jpg
    Flat rate settings: https://app.usebubbles.com/7iA23oU9ZYPFBdXxXrZnbj/comments-on-pleazo-com

    Best,
    Chris

    Plugin Support 3 Sons Development – a11n

    (@3sonsdevelopment)

    Hi @pleazo,

    Thanks for the explanation. Since that’s an issue with Dokan, it’s something they’ll have to work out. If there’s anything else you need, please let us know.

    Cheers

    Plugin Support gabrielfuentes

    (@gabrielfuentes)

    Since it’s been a while since we last heard back from you, I’m going to mark this thread resolved.

    If you have further questions, please feel free to open a new topic.

    Cheers! 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.