Support » Plugin: WooCommerce » Tax displays as $0

  • Resolved michhes

    (@michhes)


    I’m attempting to set up tax in WooCommerce for an Australian-based site. We’re selling to Australians and a 10% GST applies. However, both cart and checkout display “(Includes $0.00 Tax)” in the Total line. I’ve set my address to Australia and entered a full Australian address too.

    View and play at http://www.mysoldstickers.com.au

    I’ve configured WooCommerce/Settings/Tax/General as follows:

    * Enable taxes and tax calculations – checked
    * Prices entered with tax – Yes…
    * Calculate taxes based on: Customer shipping address
    * Display prices in the shop: Including tax
    * Display prices during cart and checkout: Including tax (I’ve also tried excluding tax, but the tax line still displays as $0)
    * Display tax totals: As a single total (have also tried Itemised)

    In Standard Rates, I have one entry:

    * Country: AU
    * Rate: 10.0000
    * Name: GST

    What am I doing wrong??? I’ve read and followed the WooCommerce Getting Started guide for tax and seen a few other recent forum posts here and elsewhere of people having a similar problem, with no resolution. I’ve now seen this problem on two different sites, the mockup I did for the main site (different server), and the main site.

    WooCommerce is V2.3.10 and I have no other tax plugins installed.

    https://wordpress.org/plugins/woocommerce/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi,

    Exactly the same problem here. I filled in the same thing but then for The Neterlands. Tried everything, display taxes incuded, excluded etc.

    When I find a solution, I let you know.

    Regards

    Did you check for the existence of this table in your database:
    wp_woocommerce_tax_rate_locations
    You will need access to phpMyAdmin

    https://wordpress.org/support/topic/problem-with-vat-tax-empty-1?replies=15

    I can’t say if this will work for you.

    Thank you very much Iorro–for the suggestion and pointing me the other post. Problem solved!

    The wp_woocommerce_tax_rate_locations table was not present so I used lupyo’s SQL statement (modified as follows to include a space after ‘TABLE’ and to remove to the single quotes before opening bracket and after the semi-colon):

    CREATE TABLE wp_woocommerce_tax_rate_locations (
    location_id bigint(20) NOT NULL,
    location_code varchar(255) NOT NULL,
    tax_rate_id bigint(20) NOT NULL,
    location_type varchar(40) NOT NULL
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8;

    As lupyo suggests, I too had to click Save on the WooCommerce/Settings/Tax/Tax Options screen. The ‘Includes $1.36 Tax’ options is now working as expected, as does the option to display prices during cart and checkout = excluding tax.

    Notably the newly created table remains empty although I haven’t yet tried putting through a test order.

    Thanks again for your assistance–here and on other posts 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Tax displays as $0’ is closed to new replies.