Support » Fixing WordPress » Takes a while to post – kinda slow … Any thoughts

  • Hello,

    I own a website using the latest up to date version of wordpress, http://www.geekinc.org and I can’t seem to figure out why it takes like 20 seconds to post what I just blogged about. To show up on the front page. I always gotta wait a long time before it posts, My site gets a fairly high amount of traffic. I was reccomened to use Gzip, and enable gears but problems still persists so which brings me here whats the deal? Any help with this is highly apreciateive.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The problem could be at your host, or it could be related to two specific things connected to WP. One – your plugins, and two – improperly written CSS for your theme. Easiest way to determine that is to switch back to the default theme and deactivate all plugins and see how fact the site loads. Then add back your plugins one at a time until you see a slowdown. If and when you do – that is your problem. Then reselect your own theme and see if there is any difference. If not the plugins are the issue. If yout theme is slow without plugins active it’s your themes CSS.

    Can I have some help getting my site to load the speed its suppose to

    Mr E

    (@ebiladdress)

    Did you change the theme? That helps tell the problem.

    Yes, I did… Maybe because I have alot of youtube videos on there but I checked that. Not sure whats going on

    Mr E

    (@ebiladdress)

    Disable things one by one, may help.

    I tried disabling all my plugins still loads slow..

    Mr E

    (@ebiladdress)

    Call the provider of your hosting. It appears to be a problem there. Also google them and see if others are saying the same thing.

    Depending on how they use DNS providers can be super slow. I use Go Daddy which is less than fast but very dependable and I find it a fair balance for the features / price.

    You may have other priorities in mind however 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Takes a while to post – kinda slow … Any thoughts’ is closed to new replies.