Support » Fixing WordPress » Takes 20 seconds to load

  • Resolved sentryair


    I just recently this week set up a blog on my employer’s website and transferred 2 years worth of posts from Blogger to WordPress. Everything is working great – except the blog initially takes 20 seconds to load. Once you’re in the blog, you can click through to individual posts and pages at normal speeds.

    The problem is getting the blog to actually start downloading – the browser just sits there at “sending request”. I don’t believe it’s the content that is slowing it down – when analyzing load times with developer tools (Firebug) – the home page is about 500kb and takes just a couple seconds to download. I did look into the optimization plug-ins but it’s not the size of the content causing this. I’ve tried disabling all the plug-ins with no change. Running external tests show the site loading at normal speeds (3-5 seconds)

    The blog is hosted on the same sever as the corporate website – which we do not have any problems with.

    Any thoughts to what I can do to rectify this problem?


Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Yes, I deactivated every plugin through the admin menus. Forgot to specify, I am using the twenty-eleven theme. I renamed the plug-in folder just to try it out and still no change.

    Also, waterfall graphs show the website opening at normal speeds.

    we have a painfully slow site at I deactivated all the plug-ins and changed the theme to twenty eleven from weaver II. This didn’t make things better – the loading speed is still TOO SLOW.

    I took the time to update all the headers to fit the new theme.

    there are not many useful widgets available with this theme. there is a search box (in the menu bar?) even though I turned it off/killed that widget.

    the two column/one column choices just change the width of the header and don’t actually move the search box into the right (or left) hand column from the menu bar – where it doesn’t belong.

    what now?

    Moderator Andrew Nevins


    Forum moderator

    As you’re not contributing to the original poster, create your own thread on the issue.

    how do i do that please?

    Moderator Andrew Nevins


    Forum moderator

    Through this link.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Takes 20 seconds to load’ is closed to new replies.