Support » Fixing WordPress » Tags seperated by . instead of ,

  • Hi!

    So I have a pretty unusual question.
    For a website of a client of mine, I need to create (product) tags that have commas in them. This is because the tags are amounts, which I use to create dynamic content.

    But of course, WP tags are comma-separated, so when adding any amount (like €9,99 which is the Dutch way of showing decimals) it splits them up in 2 tags…
    So now, temporary I am using a dot instead of comma’s (so like €9.99) but that is strictly not correct ‘spelling’.

    Is there any way (or work around) for this? Any help would be appreciated!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator bcworkz

    (@bcworkz)

    The comma is used by the editor UI to separate tags. The workaround would be to get out of the editor and go to the tags list table (under “Posts” admin menu item) and replace occurrences of a dot with the proper comma.

    The Quick edit option makes doing so relatively easy.

    Thread Starter MattSchippers

    (@mattschippers)

    Hi @bcworkz

    thanks for the reply. And I wish it would be as easy as you suggested.
    But it ain’t. Cause also in the list > quick edit mode, WP UI uses comma-separated tags…

    Any other ideas?

    Thanks!

    Moderator bcworkz

    (@bcworkz)

    ??? 🙂 Are you in the right place? Admin Menu > Posts > Tags. Hover over a tag with a dot and click Quick Edit. You’d quick edit one tag at a time, comma separation isn’t a thing there..

    If you have a huge number of tags where even that would be onerous, you could compose a SQL UPDATE query that finds all instances of dots in tag names and changes them to commas. Might involve the REGEXP_REPLACE() function. I’m not totally sure though, SQL isn’t my strong suit. Best to do so from within phpMyAdmin. Not a good thing to attempt from WP IMO.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.