Support » Alpha/Beta/RC » Tags not working: issue with WP2.8 and DB Cache plugin

  • Resolved Erunafailaro


    I’ve reproduced this issue on several installations with WordPress 2.8-beta2 and DB Cache 0.6:

    • setup a blog with WordPress 2.8beta2
    • install the DB Cache plugin and activate it
    • write a new post and add some tags to it
    • safe the tagged post or publish it
    • open the post again and add some new tags
    • add some tags to the post that are already being used in another post
    • save the changes

    You will see, that not all changes of the tagging for this post will be saved successfully.

    To fix this, do the following:

    • deactivate DB Cache
    • delete all files that DB Cache has created in /wp-content (especially /wp-content/db.php)

    Repeat the editing of the post’s tags. Everything will work now.

    Maybe there is a compatibility-issue between DB Cache and WordPress 2.8? This could be related to this issue:

Viewing 13 replies - 1 through 13 (of 13 total)
  • Maybe there is a compatibility-issue between DB Cache and WordPress 2.8? This could be related to this issue:

    I’d say the problem isn’t related to that ticket if when you deactivate the db-cache plugin, you are able to successfully assign existing tags to posts.

    Not related but will add this link for plugin author’s info:

    Ticket #9972 describes an incompatibility between an older version of HyperDB and WordPress 2.8 and not a bug in WordPress 2.8.

    As DB Cache uses HyperDB I would say, that there is a relation to this ticket. Although the problem is not located on the WordPress-side, but on the side of the plugins HyperDB and DB Cache.

    I had problem with editing comments and adding tags at all.
    Disable DB Cache solve this problem after upgrading to WP2.8
    This works for me. Thank you.

    I have this problem too and have spoken to several others who are having it. Absolutely love this plugin, please release an update to fix this issue 🙂

    My problem is worse than Erunafailaro described (no tags in new articles, no tag editing in existing articles) but the workaround is a lot easier:
    disable db-cache (NOT deactivate, just disable it on the options page)

    I’ve found the same problem with WP 2.8.1. I didn’t see the problem with 2.7.1. Here’s a simple way to reproduce it:

    1: enable db-cache
    2: write a wordpress comment
    3: edit and save the comment
    3a: Note that the edit doesn’t take, instead you still see the old comment 🙁
    4: disable db-cache
    5: edit and save the comment
    5a: Note that the edit is accepted ok 🙂

    This is a totally groovy plugin. It gives a nice performance boost to WordPress. I hope an update is easy to implement.

    Problem exists with WP 2.8.2 and DB Cache Version 0.6. I had to disable the plugin for now.

    Problem exists with WP 2.8.2 and DB Cache Version 0.6. I had to disable the plugin for now.

    I have the same problem i hope an update comes out soon, i wanted to change from wp-supercache 🙁

    I’m glad that I’m not alone with the admin panel comment editing problem after upgrading to the earliest version of WP 2.8. As I hadn’t been posting new entries in my watch blog since last April, I didn’t notice any problems until very recently.

    I did not realize that DB Cache was incompatible with version 2.8 upwards, thinking it was a quirk of WP 2.8. Currently I’m running WP 2.8.4 and after seeing that the comment editing and tagging problems persistent, I Googled for an answer and found a post stating that DB Cache was the culprit.

    I disabled DB Cache and tried to edit one of my readers’ comments. It worked flawlessly. When I re-enabled DB Cache, the symptoms returned. I later found out that the author of DB Cache has yet to update this plugin to work with WP 2.8.x.

    IMO, my blog appears to perform faster with DB Cache enabled (along with WP Super-Cache), therefore while waiting for DB Cache to be updated for compatibility with WP 2.8 all I have to do is to temporarily disable it when I have to edit comments and turn it back on when I’m done.

    I know it’s not an elegant workaround but I’m already addicted to DB Cache until I find something equivalent or better. 🙂

    On an unrelated note, I also discovered that the automatic upgrade of WP core files within the admin panel usually fails unless I manually disable all active plugins. While the instructions tell you to back up your databases before upgrading (of course I do backup my WP database before performing the auto upgrade), WP unfortunately doesn’t tell you to disable your plugins first.

    I assumed that the upgrade job will take care of that for you (for example, upgrading an individual plugin within the admin panel will automatically disable the current plugin first), but it looks like WP doesn’t disable all of your plugins.

    You have to remember to disable all active plugins first before performing the automatic WP version upgrade and go through the list of plugins that require manual enabling after upgrading to the latest WP version. A good example is the WP Super Cache plugin, which always defaults to “OFF” whenever it is disabled albeit temporarily.

    No need to disable any plugins when upgrading… it have nothing to do with upgrading. There is something wrong in your installation, not with wordpress. i ALWAYS upgrading without backuping DB or disabling plugins-it works always.

    I can confirm this porblem. It started to happen yesterday. Also using:

    WordPress 2.8.4
    DBcache 0.6

    I hope this will get fixed soon as DBcache really did speed up my site allot.

    There is a new plugin that does the same as DBCache and it is working with WP2.8+:

    DB Cache Reloaded

    So the solution for all of you would be to uninstall DBcache 0.6 and to install DB Cache Reloaded instead.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Tags not working: issue with WP2.8 and DB Cache plugin’ is closed to new replies.