WordPress.org

Support

Support » How-To and Troubleshooting » Tagline not showing

Tagline not showing

  • Hello,
    I’m tearing my hair out trying to figure out why my tagline isn’t showing. Here’s the code:

    <header role="banner">
    		<a href="<?php echo home_url( '/' ) ?>" id="logo">
    			<?php $url = of_get_option( 'logo' );
    
    			if (!empty($url)) { echo "<img src=\"$url\" alt=\"\">";
    			}
    
    			else { bloginfo('name'); }
    		?></a>
    		<div class="tagline">
    		<p><?php bloginfo('description'); ?> </p>
    		</div>
    
    		<?php wp_nav_menu( array ( 'container' => 'nav', 'theme_location' => 'primary', 'fallback_cb' => false ) ); ?>
    	</header>

    and the link: link here

    Many thanks in advance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • <?php bloginfo( 'description' ); ?> the spaces are required before and after the ( and )

    Thanks or your answer. I fixed the spaces but it still doesn’t work. Its not in the source code either.

    Try:

    replace:

    <p><?php bloginfo('description'); ?> </p>

    with

    <h2><?php bloginfo( 'description' ); ?></h2>

    The <p> may be being stripped

    no, that’s not it either. Why would the <p> be stripped?

    Michael

    @alchymyth

    Forum Moderator

    the tagline is for instance showing in the ‘about’ page (I haven’t tested any others);

    check if for any reasons your theme is using a different header for the home page.

    best place to contact is themeforest as the seller of your theme;

    this WordPress forum does not support commercial themes (partly because there is no free access to all theme files).

    Aha!(smacking self on forehead). Actually I’ve reworked a lot of the theme and I forgot I didn’t include the header on the front page. That’s good to know about the forum not supporting commercial themes. Thanks for your answer.

    Hello! It also might be useful for you to know that you can get support for the theme by contacting the author through their profile page. Specifically, for the theme Float, the author’s profile page is here: http://themeforest.net/user/myTheme

    Hopefully you’ve managed to work the issue out now anyway though 🙂

    Thanks for that. I did actually contact the author about another issue and got no response so I didn’t try again but I will try to contact him/her again.

    I’m sorry to hear that, hopefully they get back to you promptly this time.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Tagline not showing’ is closed to new replies.
Skip to toolbar