Support » Plugin: Infusionsoft Official Opt-in Forms » Tagging on form submission?

  • Hi there – great to see an official Infusionsoft plugin for WordPress; great stuff.

    There doesn’t seem to be any options for tagging people in Infusionsoft once the form is submitted. Am I correct in thinking that? Right now, it looks like I can submit the form but that I cannot tag anyone.

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The plugin works by allowing you to create optin forms of all different types that look great (thanks to Bloom plugin fork from Elegant Themes the makers of Divi).

    1. You have to link your Infusionsoft Account (api key and app name) in the WordPress Infusionsoft Plugin under Settings.
    2. Once this is done you can create a campaign inside Infusionsoft and there is a new goal called WordPress Opt-in near the bottom of the goal list.
    3. Choose this goal and then do everything you normally do to create a sequence that applies tags and link the goal to the sequence.
    4. DON’T FORGET: You need to choose the optin form on the goal by double clicking the goal

    P.S. As of 2017-05-31 There is currently a bug for some users where if you create multiple opt-ins only the newest one will show up in the Goal to select inside Infusionsoft. This is a known issue they are working to resolve.

    • This reply was modified 2 years, 5 months ago by matthewburt.

    Thank you Matthew – that’s a great help.

    Unfortunately – and possibly related to the bug you mention – when I double click the WP Opt-in Goal to assign a form to the goal, I do not see any forms available at all.

    I created a short video here which shows you the issue I’m having.

    If you have any insight into why none of my opt-in forms are showing in Infusionsoft, that would be great. My app is authorized and connected with no problems – and replicated the problem in Chrome, Safari and Firefox (Mac).

    Thanks again,

    David

    Watched the video and I am 99.9% sure that this is directly related to the bug I mentioned. I’ve already spoken with support and they assured me this was a known issue they are working on as we speak. Mine showed the newest one only but wouldn’t show any others. Yours not showing any at all is a bit odd but you also have A LOT more forms than I did.

    The crazy thing is, I just now had to delete all forms, remake the ONE I actually had working from scratch and obviously change the shortcode ID on my blog post content upgrade to get the form to work.. even though I never re-published my campaign after adding in the second optin goal/sequence.

    Hope they get it fixed soon, I’m frustrated as well.

    PS
    You might try contacting support as well to let them know you’re not seeing any and that you have a lot of optins created. It may help them? Who knows… I used the chat option in infusionsoft when you click the ? at the very top bar

    • This reply was modified 2 years, 5 months ago by matthewburt.
    • This reply was modified 2 years, 5 months ago by matthewburt.

    Thanks Matthew – appreciate the speedy response. When writing, I assumed that you were replying on behalf of the Infusionsoft Dev Team – which, I now realise, is probably not the case – so thanks for stepping in.

    I’m going to raise this with their support team as well.

    Thanks again.

    Yeah, lol I was trolling these forums while I waited on chat support haha, figured there might be others who needed help

    So, I had a long (LONG) chat with IS support and this is what we discovered:

    – all the forms I had created had a hyphen in them, and that seemed to be the underlying problem.

    – if I created new forms – without hyphens in the title – they displayed in the IS Campaign builder just fine.

    – annoyingly (because I have 25+ forms) I couldn’t just rename the form and have it display, nor could I duplicate the form and rename that. I had to re-create the form from scratch and not have hyphens in the title.

    So, that’s what I’m doing now … and it seems like it’s working so far.

    David

    good grief.. yeah I have the date of the blog posts in my title. Example: “2017-05-30 Blog Content Upgrade Title”

    very annoying.. I NEED MY HYPHENS

    So you are going to have to recreate all 25+? You can’t just rename?

    Never mind, I re-read and realize you already stated you HAVE to rename. I actually figured that out myself but I was hoping I was wrong. I had to delete everything too but I put in one form only with hyphens and it showed up. I’m sure if I add another it will break.

    • This reply was modified 2 years, 5 months ago by matthewburt.

    Right – so everything has to be re-created, I can’t rename. And, worse, it looks like I can’t duplicate and edit either … that seemed to screw things up again. So, each one is being re-created from scratch!

    That’s a FUN evening ahead of me …

    – and yeah, if I have hyphens in the titles, only the last one shows up.

    I think I know why the duplicate (and in turn the split test) doesn’t work either.. UNDERSCORES

    I assume it’s the same problem as the hyphens, only this time we are not in control of the naming conventions. It either puts _copy or_child at the end of the name depending on duplicate or split test respectively

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Tagging on form submission?’ is closed to new replies.