Support » Plugin: FooBox Image Lightbox WordPress Plugin » tag visible at the bottom of the page

  • Resolved bonovski

    (@bonovski)


    Hi, there is a span tag visible at the bottom of the page after latest update:

    <span class="foobox_font_preload">f</span>

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author bradvin

    (@bradvin)

    Hi @bonovski

    It seems like your site’s CSS is being cached. Can you please purge your cache if you are using a cache plugin. The update contains new CSS which hides that element in the page.

    If you still have issues, you can turn off the font preloading which removes that element from the page. To do that, add this code to your functions.php file:

    
    function turn_off_fobox_font_preload($preload) {
      return false;
    }
    add_filter('foobox_generate_javascript_preload_font', 'turn_off_fobox_font_preload');
    

    Hi Brad ( @bradvin )

    I’m having the same problem as @bonovski. There was a transparent line at the bottom of those pages that load the FooBox assets (also on the landing page), showing an “f” in the left bottom corner.
    Flushing WP cache and renewing browser cache didn’t help.

    I temporarily downgraded to 2.6.4 again, no problems with this version.

    Best regards
    Oliver

    Plugin Author bradvin

    (@bradvin)

    @bonovski did you try adding the code to your functions.php ?

    Sorry, was absent for a few days.

    No, the problem went away after multiple refreshes and disabling and enabling foobox and foogallery.

    I don’t have any caching enabled in my dev environment any I always use a private browsing window but wordpress sometimes just “won’t let go” …

    Just had the same problem. Rather than messing about with functions.php I just put the following in the site’s CSS file:

    .foobox_font_preload {
    display: none;
    }

    Thanks for that tip, @gpwebdesign68! I prefer that over editing functions.php.

    But I wonder why I should do this at all. To me it’s a bug because there’s an empty line on the bottom of every page loading the FooBox Assets. This cannot be an planned side effect of font preloading, can it?

    Plugin Author bradvin

    (@bradvin)

    hey @oschmehr – the span should not be visible on your site. It has always been in the plugin, but in the most recent update, we moved the inline CSS (which hides the span) to be inside the FooBox main css file.

    If the span is showing, then either your caching plugin needs to be purged/cleared (if you have one) or the browser cached needs to be cleared so that it downloads the latest foobox css.

    Either way, our next major release of FooBox will be moving across to SVG and we will be dumping the use of fonts – they just cause too many issues

    Hey @bradvin, thanks for the quick update!

    I definitely cleared my WP Cache (WP Fastest Cache) and my browser cache (Chrome: [SHIFT] reload) serveral times, but no change.

    Anyway I stick with CSS hack mentioned above for the moment and wait for the next major release.

    Regards
    Oliver

    Plugin Author bradvin

    (@bradvin)

    hey @oschmehr

    If you are using WP Fastest Cache, you need to “Delete Cache and Minified CSS/JS” and not just the “Delete Cache”

    @bradvin Good hint, but I always clear everything including CSS cache.

    Anyway as a logged-in admin I get to see the uncached version always, but still there was that empty line at the bottom.

    You have forgotten to add the “display:none” in foobox.noie7.min.css

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.