Support » Plugin: Yet Another Related Posts Plugin (YARPP) » Tag Relatedness Is Not Working

  • Resolved Moondrop



    I am unable to get posts to display that share the same tags, and just get ‘No related posts’.

    I have turned on the “Relatedness” option in the setting and have tried thresholds ranging from 1-4. I have also tried all the different weight options for tags, and turned off category considerations. No tags are disallowed in “The Pool”.

    I am able to get only categories to display related posts, however I want both tags and categories to be considered. Any help would be much appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Sorry to hear this hasn’t been working as expected. 🙁 I’d like to better understand what’s going on.

    Just to check:
    1. when you turn off “consider tags”, and have “consider categories” on, you get results.
    2. when you have both “consider tags” and “consider categories” on, you don’t get results.

    Is that right?

    Hi Michael, thanks for the reply.

    Just as I was retesting the plugin, in order to provide you answers for your questions, the tags considerations are now working properly. I have no idea why it was not working before, as I have not done anything different, however I’m glad it’s working now!

    Every so often though, new tag or category assignments to posts do not refresh the displayed related posts. A post that been de-tagged and de-categorised will still display as a related post. Is there a way to refresh it?

    Once again thanks for the reply. =)

    Ah, yes. The caching in YARPP is pretty aggressive now, and only clears when certain types of changes are made.

    If you ever need to flush the cache and force everything to recompute, you can add an option to do so by installing the YARPP Experiments plugin.

    Glad the initial issue is resolved, though. 🙂

    Thanks Michael, I’ll be sure to try out the YARPP Experiments plugin.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Tag Relatedness Is Not Working’ is closed to new replies.