• Resolved lieno

    (@lieno)


    Hi,
    after upgrading wordpress 5.6 on litespeed web server enterprise i recived trouble with tag manager in Site Kit by Google, i’m using it for analytics code and other tracking code, but now i dont have traffic from my site in analytics. Snippet is inserted. If i turn on snipet only from amalytics work good, when i turn on tag manager snipet – not work and don’t see any traffic.
    What can be a trouble with that? How to decide?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Thanks for reaching out. When you’re checking for Analytics traffic are you performing a check using the Analytics live reporting tool? If so please check and ensure you are viewing your site as a non logged in user, it’s possible your Analytics configuration may not count logged in traffic.

    Another thing to check is that you have “Published” your latest tags within Tag Manager.

    If you find that traffic is not being reported after performing the checks above please share your Site Health information using this form and we can check your setup.

    Thread Starter lieno

    (@lieno)

    Hi again,
    i’m have big taffic on site. When i’m self check i use incognito. All my latest tags is published.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for sharing. I’ve checked your details and on the URL you provided in the form (not the additional URLs you’ve listed in the “Additional information” field there doesn’t seem to be any Analytics tracking code, via Tag Manager or manually placed.

    As I can see the Google Tag Manager Snippet has been successfully placed via Site Kit, as confirmed in your Site Health information the issue may lie at Tag Manager level or with third party plugins. I noticed you’re using LiteSpeed Cache, can you temporarily deactivate this plugin on that site before checking once more? Minification or combining of assets can result in unpredictable behavior or snippets placed on your site.

    Let me know once you’ve temporarily deactivated LiteSpeed and I can check. We can then reactivate and troubleshoot your configuration should Analytics work as expected.

    Thread Starter lieno

    (@lieno)

    I temporarily deactivated LiteSpeed. Now i see my traffic. Interesting, what in litespeed plugin can disable Tag manager ?

    Thread Starter lieno

    (@lieno)

    It’s strange, becuase before update on wordpress 5.6 all work perfect together. I don’t remeber about update litespeed plugin (was updated only server level on version LiteSpeed Web Server Enterprise 5.4.11).

    • This reply was modified 1 year, 8 months ago by lieno.
    • This reply was modified 1 year, 8 months ago by lieno.
    Plugin Support James Osborne

    (@jamesosborne)

    There are a few options to check, including the below if you’re finding the traffic was not appearing for you only, as a logged in user:

    • Cache > Do not cache roles > Administrator
    • Cache > Cache Control Settings > Cache Logged-In users

    If you find the issue is occurring for all users there may be minification or combining of assets resulting in this behavior. There may also be configuration options you can apply to exclude particular snippets, I noticed an “Exclude” option under “Cache > Excludes” setting.

    Let me know whether you’re able to get it working as expected.

    Thread Starter lieno

    (@lieno)

    I switch off:
    1. Cache Logged-in Users
    2. CSS Minify and CSS Combine
    3. JS Minify and JS Combine
    4. HTML Minify
    5. Removed Administrator from Do not cache roles.

    But it didn’t help.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for the update. I’m afraid I can’t be sure what configuration might be resulting in this behavior. I’ll put some time aside to test various configuration when time allows, but for the moment can you try and reset all plugin settings before checking once more? (Toolbox > Import / Export > Reset All Settings)

    Thread Starter lieno

    (@lieno)

    ok thnx for all. As result of this I found trouble in litespeed plugin: Localize Resources, if it turn ON after that don’t work tag manager.

    Plugin Support James Osborne

    (@jamesosborne)

    Thanks for providing an update, that’s interesting to know. I’ll keep this in mind should other users also be impacted.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Tag manager not working’ is closed to new replies.