WordPress.org

Forums

Tag <param> is cleanup ..editor TinyMCE 3 (1 post)

  1. ronny villarroel mendoza
    Member
    Posted 6 years ago #

    I have insert this code:

    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0" height="385" width="480"><param value="#ffffff" name="bgcolor" /><param value="flashshowid=' + idvideo + '&amp;baseurl=http://www.realestateshows.com/&amp;playmode=embed" name="flashvars" /><param value="http://www.realestateshows.com/show/player.swf" name="src" /><embed height="385" width="480" src="http://www.realestateshows.com/show/player.swf" flashvars="flashshowid=' + idvideo + '&amp;baseurl=http://www.realestateshows.com/&amp;playmode=embed" bgcolor="#ffffff" type="application/x-shockwave-flash"></embed></object>

    this code is inserted using a custom bottom of my TinyMCE that I create.

    the flash video is inserted in VISUAL view but when i change to HTML view the code is cleanup to :

    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0" height="385" width="480"></object>

    I need the <param> tag for the 'idvideo' why the editor is cleanup this tag ?

    In my plugin I have the code for validate the tags:
    $init_array['valid_elements'] = 'object[classid|codebase|height|width],param[name|value],embed[*],*[*]';

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 6 years ago by ronny villarroel mendoza
  • This topic is not resolved
  • WordPress version: 2.5