Support » Plugin: Tag Groups » Tag Group missing

  • Resolved liminalseattle

    (@liminalseattle)


    We had a tag group that went ‘missing’. Cannot create another version as it says that it already exists, but it’s also not in this list of all tag groups nor is it something we can add tags to….

    Here’s a screenshot of me trying to make a tag group for the missing ‘Washington’ group: https://imgur.com/a/BHmDoJk

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Chris

    (@camthor)

    Sorry about that issue!

    Anything special you did before that? You don’t seem to have many groups yet – if you try the alphabetical sorting in the tools below the groups, does it re-appear or can you then create that missing group?

    Or: Try to create any other group and delete that temporary group again. Then try if it works now.

    I don’t know yet how it happened, but I will add to the next version a check to fix any ghost labels.

    We added a new tag group and then the Washington one disappeared. When we try to create a new one called ‘Washington’ it says it already exists (the screen shot shows that message).

    Sorting by alphabet doesn’t make it return.

    I created a temporary group and deleted it. Still not able to make one for ‘Washington’ and it’s still not showing up in the list.

    What table are the tag groups stored in? I can poke around phpmyadmin and see if there is anything bizarre there?

    Plugin Author Chris

    (@camthor)

    In the options table should be entries with the keys “term_groups” (all IDs of the groups) and “term_group_labels” (each ID with the group name). They are stored as serialized arrays. I assume that “term_group_labels” is too large and that you find “Washington” there. You could for example change “Washington” to “xxxxxxxx” – then the faulty entry is still there but won’t disturb you anymore. (Until I solved it in the next release.)

    (All assuming that you use the latest version.)

    Hi Chris,

    We’re using the latest version.

    Washington is indeed in the term_group_labels:

    a:12:{i:0;s:12:"not assigned";i:1;s:10:"Washington";i:2;s:7:"Florida";i:3;s:10:"California";i:4;s:7:"Georgia";i:5;s:8:"Colorado";i:6;s:4:"Utah";i:7;s:8:"Illinois";i:8;s:7:"England";i:9;s:6:"Oregon";i:10;s:5:"Chile";i:11;s:5:"Idaho";}

    Here are the term_groups:

    a:10:{i:0;i:0;i:1;i:9;i:3;i:7;i:4;i:11;i:5;i:4;i:6;i:2;i:7;i:8;i:8;i:5;i:9;i:10;i:10;i:3;}

    changing to ‘XXXXXXX’ just made it so none of the tag groups showed up on the background.

    Plugin Author Chris

    (@camthor)

    Sorry, should have told that the number of X should be matching those of Washington.

    Something different: Please return the original term_groups_labels and replace term_groups by:
    a:11:{i:0;i:0;i:1;i:9;i:3;i:7;i:4;i:11;i:5;i:4;i:6;i:2;i:7;i:8;i:8;i:5;i:9;i:10;i:10;i:3;i:11;i:1;}

    Thanks Chris,

    I tried that but it didn’t work.

    However, I replaced the Washington term group with a ten char ‘XXXXXXXXXX’ and that worked.

    Then I did a sql update to change the term_group for all the matching rows to switch to the new term_group id. Seems to have worked.

    Plugin Author Chris

    (@camthor)

    The fact that the latest suggestion didn’t work makes it more mysterious but maybe the serialized format wasn’t OK yet.

    There should be only one entry for “term_group” but running that sql certainly doesn’t do any harm.

    The next release will fix a bug regarding where new groups are positioned and it will also try to identify and remove orphaned labels so that at least they won’t block anything.

    Thanks for your help with debugging!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.