Support » Plugin: Tag Groups » Tag Group Administration

  • Resolved moonyell

    (@moonyell)


    Hello,

    I have been testing this plugin and during setting process, backend page of Tag Group Administration tags doesn’t load.

    I have checked there is same issue in the forum: https://wordpress.org/support/topic/tag-group-administration-tags-doesnt-load

    The issue was resolved since it was caused by an error of file admin-ajax.php. However, from my side, I did not find this file.

    Would you please let me know where this file is?
    Thank you

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Chris

    (@camthor)

    The file is in /wp-admin/ .

    However, it is very unlikely that your WordPress core installation is also corrupt, like in that other case that you linked to. In that case the file has been modified. I don’t assume that you modified exactly the same file, but you can try to reinstall the core files from the menu Dashboard -> Updates.

    Please make sure you first tried these steps: https://documentation.chattymango.com/documentation/tag-groups/troubleshooting/the-list-on-the-tag-groups-page-doesnt-load-i-only-see-the-wheel-spinning-forever/ The most important are the Ajax Test and trying with other plugins deactivated.

    moonyell

    (@moonyell)

    Hi Chris,
    It’s been very hard to visit wordpress.org from China recent months. But I neither could submit feedback to your on your website.

    Briefly saying I have tried all possibilities you mentioned but the problem remains same.
    Just wondering if it requires connection between user of tag-groups and a remote server when setting the plugin? If so it might be inconsistent connection of internet from my side.

    Very frustration, I have to admit.

    Plugin Author Chris

    (@camthor)

    The plugin requires a working connection between your browser and the server where your WordPress installation is running. That is something very common in WordPress. Even without any plugin installed, there is frequent communication between your browser and your server.

    Can you please confirm:

    • The problem also persists with ALL other plugins deactivated and switched to a default theme?
    • The mentioned Ajax Test shows OK?
    • The mentioned JavaScript Console does not show any error messages?

    Which version of PHP do you use?

    It can always be that your server has an unusual configuration. Or something disturbs the connection. Without any error messages it is only possible to make guesses.

    moonyell

    (@moonyell)

    Hi Chris,
    I think very likely it’d be connection problem. Recent months it’s been very difficult to upgrade to new version for other installed plugins from my end. But curiously meantime whenever I successfully downloaded a new plugin I could install it to my system, except tag group.

    Plugin Author Chris

    (@camthor)

    It is possible that your other plugins don’t communicate in the background with the server and therefore don’t experience that problem. The most common cause for that symptom are invisible error messages or warnings (from any plugin that is active on that system), that disturb the communication but maybe it is here indeed a problem with the speed.

    I am not sure. I checked error.log and nothing related found.
    By the way, would you kindly let me know if the pluging would let display tags under a specific category in a page; not posts list with the tags but a pape showing only tags of a certain category. For example, tags of restaurant, cafe, bar of category of New York.

    Plugin Author Chris

    (@camthor)

    I would expect more useful error messages in the console in your browser, see https://webmasters.stackexchange.com/questions/8525/how-do-i-open-the-javascript-console-in-different-browsers/77337#77337

    Unfortunately, the plugin is not able to filter posts by tags/tag groups and category. The pages where the links from the tag clouds lead to are just the default tag (archive) pages of WordPress. These pages only filter posts by tag, not by category.

    From my chrome, it reads:
    [Deprecation] HTML Imports is deprecated and will be removed in M80, around February 2020. Please use ES modules instead. See https://www.chromestatus.com/features/5144752345317376 and https://developers.google.com/web/updates/2019/07/web-components-time-to-upgrade for more details.
    Nothing more. Seems everything is accessible for I use a vpn connection.
    upgrading of other plugins can be obtained too.

    On my question of plugin functions, I intended to include some tags into a certain group, and a page will show those chosen tags under this specific group(not category), this is why you name your plugin, I guess.

    More browser tip info:

    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    how-do-i-open-the-javascript-console-in-different-browsers:1 A cookie associated with a resource at http://quantserve.com/ was set with SameSite=None but without Secure. A future release of Chrome will only deliver cookies marked SameSite=None if they are also marked Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5633521622188032.

    Plugin Author Chris

    (@camthor)

    In the logs I cannot see any problem. What you pasted are something like informative alerts. If the groups in the admin don’t load, the error console shows an error and a reason (blocked, URL returns error, result cannot be understood etc.)

    Does this problem appear also using another browser?

    Yes, tags can be shown under groups, the way you organized them in the backend. You can see an example here: https://demo.chattymango.com/examples-of-the-tabbed-tag-groups-cloud/ What you see in the tabs are group names, below are the corresponding tags.

    Hi
    I just am testing on a different browser. Just remains exactly same.

    As a result of Ajax test, the reponse is:
    <?xml version=’1.0′ encoding=’UTF-8′ standalone=’yes’?><wp_ajax><response action=’tg_ajax_manage_groups_0′><object id=’0′ position=’1′><response_data><![CDATA[success]]></response_data><supplemental><message><![CDATA[This is the regular Ajax response.]]></message></supplemental></object></response></wp_ajax>

    Is there anything wrong?

    Plugin Author Chris

    (@camthor)

    The Ajax response looks good, but there might be empty lines/spaces before (or after) the response, caused by another file. This can happen, for example, when a WordPress file doesn’t start with <?php directly at the very beginning.

    You could check wp-config.php because this file is sometimes modified by plugins or users and it won’t be renewed when you update your WordPress installation.

    wp-config.php looks right.
    Well, I am going to deactive the plugin temporary, till find out the cause of the issue.
    If you have any clue or upgrading of this plugin, please kindly leave a comment here so that I can be notified from Email.
    Best wishes,

    Plugin Author Chris

    (@camthor)

    I have created a development version, which uses a different approach. Currently having a problem to provide it via wordpress.org. If you send me a short message via https://chattymango.com/support I will send you a link with the ZIP file.

    Chris, Jesus, I always failed captcha. But I am a human.
    I would love to have the newest zip. please drop to moonyellatgmail.com

    By the way, do you think if it’d be helpful if I copy the source codes of the setting page with chrome? I have no idea of coding things.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Tag Group Administration’ is closed to new replies.