WordPress.org

Support

Support » Plugins and Hacks » Tabs suddenly not working

Tabs suddenly not working

Viewing 15 replies - 1 through 15 (of 33 total)
  • Sorry, no solution but I have exactly the same problem! Opening a accordion does not work anymore. Strange because the test sites from TheThe Tabs work.

    gnosis_wp
    Participant

    @gnosis_wordpress

    What theme are you using?

    Switched to:

    http://kav.in/projects/blog/wp-ui-quick-start/

    None of these worked:
    http://wordpress.org/extend/plugins/put/
    http://wordpress.org/extend/plugins/thethe-tabs-and-accordions/
    http://wordpress.org/extend/plugins/jquery-ui-widgets/

    and they used to.

    My theory is that all the ones that we typically use point to a library on an external server which may not be available any longer (outage of blocked).

    Matt Lowe
    Member

    @shoestringsites

    Looks like an incompatibility with the latest version of jQuery as pulled in through googleapis. The plugin pulls in the latest version automatically, add this to your theme’s functions.php as a temporary workaround until the plugin is fixed:

    function thethe_fix() {
        wp_deregister_script('jquery');
        wp_enqueue_script("jquery", "//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js", array('json2'), '1.8.3');
    }
    add_action( 'wp_print_scripts', 'thethe_fix', 20 );

    [Moderator Note: Please post code or markup snippets between backticks or use the code button. As it stands, your posted code may now have been permanently damaged/corrupted by the forum’s parser.]

    Note that this will fix your site onto version 1.8.3 of jQuery, which might not be a good thing long term.

    Same here… Since yesterday my accordions and tabs don’t work (while the toogles work fine). Your code hides the tabs and shows the whole content at once – was it suppose to do something more?

    Anyway: I (and not only me as I see) really need a fix for this plugin, pls, help! 🙁

    Matt Lowe
    Member

    @shoestringsites

    Odd, sounds like for you it’s deregistering jquery but not re-registering it. What’s your site URL?

    Matt Lowe
    Member

    @shoestringsites

    function thethe_fix() {
        $protocol = (!empty($_SERVER['HTTPS']) && $_SERVER['HTTPS'] !== 'off' || $_SERVER['SERVER_PORT'] == 443) ? "https:" : "http:";
    
        wp_deregister_script('jquery');
        wp_enqueue_script("jquery", $protocol."//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js", array('json2'), '1.8.3');
    }
    add_action( 'wp_print_scripts', 'thethe_fix', 20 );

    Ah, just tried my previous code block on WP 3.4.1 and it behaves as you suggested. This updated version should see you right.

    It works! Thank you SO much! 🙂 Should I delete this after a month or so and check if the plugin is fixed? And why actually if so?

    Matt Lowe
    Member

    @shoestringsites

    Yes, don’t leave this on your site indefinitely as it locks your site down to v1.8.3 of jQuery. If you just leave it on there then it will undoubtedly cause problems with other plugins somewhere in the future. A month sounds like a good period, or if you see an update for TheTheFly Tabs & Accordions then take this off.

    The issue, at a quick glance, appears to be either an incompatibility between the latest version of jQuery and the plugin, or perhaps between the latest version of jQuery and jQuery UI. Hopefully we’ll see an update to the plugin, jQuery UI or jQuery itself in the near future and, when we do, this workaround will no longer be necessary.

    gnosis_wp
    Participant

    @gnosis_wordpress

    Matt Lowe
    Member

    @shoestringsites

    Post UI Tabs works in my lab. Checking the code it is pulling in version 1.8.3 (shipped with WP 3.5), same as my workaround above (except I pull it in from Google APIs).

    jQuery UI Widgets has a clear disclaimer on the plugin page:

    “Important! This Plugin requires WordPress 3.5 as it uses the jQuery UI 1.9 library shipped with this version of WordPress.”

    So it is using the shipped version of jQuery UI, not the version on Google APIs. On installing I can verify it doesn’t pull in jQuery from Google APIs. I’ve not tested it, but I would expect it to work.

    @matt Lowe, you are my hero! Thanks a million times and greetings from the Netherlands. 🙂

    Chris
    Participant

    @camthor

    The function thethe_fix() did the trick. Thanks a lot!

    alfonso_araujo
    Member

    @alfonso_araujo

    @damnsharp: you made my day!!!, thanks my friend for your help from Mexico. 😉

    @matt Lowe: you are the one! thanks a lot!

    Haha, the menu manager doesn’t work now – to change the menu tabs order you have to delete the fix-code, reorder the menu and than paste the code back. 🙂 So you were right (again), it’s only a temporary solution. Has anyone written to Thethefly about this issue?

    Matt Lowe
    Member

    @shoestringsites

    Hi piotrek, well spotted. This update will stop the temporary fix from interfering with the admin interface:

    function thethe_fix() {
        $protocol = (!empty($_SERVER['HTTPS']) && $_SERVER['HTTPS'] !== 'off' || $_SERVER['SERVER_PORT'] == 443) ? "https:" : "http:";
    
        wp_deregister_script('jquery');
        wp_enqueue_script("jquery", $protocol."//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js", array('json2'), '1.8.3');
    }
    if (!is_admin()) add_action( 'wp_print_scripts', 'thethe_fix', 20 );

    There is a thread on their support forum regarding the issue, but I’ve not seen any official update from TheTheFly yet.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Tabs suddenly not working’ is closed to new replies.