• Resolved sray69


    WordPress Version: 6.2.2
    Theme Name: Astra Child
    Theme Version: 1.0.0
    PHP Version: 8.2.7

    Currently (time of writing this post and during testing) Installed Plugins/Versions
    Astra Pro: 4.1.6
    Gutenverse: 1.8.6
    LiteSpeed Cache: 5.5
    Plugin Notes Plus: 1.2.6
    Starter Templates: 3.2.6
    UpdraftPlus – Backup/Restore: 1.23.7
    WooCommerce: 7.9.0

    For some reason when I tried to go to a page on my staging site today that has the Gutenverse Tabs Block, I was unable to see the content of the tabs and/or navigate to any of the tabs. After MUCH research I narrowed it down to ONLY logged in users can view/navigate the tabs.

    I disabled all plugins except the Gutenverse plugin, purged all cache, cleared browser cache and closed restarted browser, and the problem still exists no matter what type of block is in the tab.

    I have looked and I do not see any display conditions for elements/blocks on the pages that have the Tabs block. In fact I created a new page and tested it.

    If I deactivate the Gutenverse plugin I can then see all the content of all the tabs on one page, obviously with no tabs. If I activate the plugin then all the content disappears and all I see is empty tabs.

    If I Inspect the page in the browser, while not logged into my site, I can see the following CSS

    .guten-tabs .tab-body .tab-body-item {
    display: none;

    I could force these to display by changing that to “block” but that does not enable me to navigate the tabs and I am not sure yet how to enable those. Added note, all my custom CSS is done in the WPcode Lite plugin that is deactivated during testing so I am not sure why the display is disabled for these.

    Here is a video showing the issue.


    I am hoping that I am missing something and it is an easy fix. It took me a long time to find a solution that worked for my tabbed content.


    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Pradnya


    Hi @sray69,

    We’ve attempted to replicate the problem, but unfortunately, we couldn’t find the exact issue you mentioned. To proceed, could you create a new page that includes the Gutenverse Tabs so that we can further checks on your site?

    Thread Starter sray69


    I ended up setting up my tab pages with a different tab block just in case this did not get resolved, but I would prefer the Gutenverse one if we can get it to work for all users. Here is a Gutenverse Tab page for you to check.


    Plugin Author Yoga


    Hi @sray69

    It seems the issue caused by JS caching.
    Try checking your litespeed cache setting in Dashboard -> Litespeed Cache -> Page Optimization -> JS Setting.
    Make sure the setting is off (check screenshot).

    Minify sometimes could create bug because the functionality doesn’t load properly.
    Also, our JS files already minified and lightweight, so there is no need to minify it further.
    If you really need this feature, try looking for a caching plugin that could minify without breaking the original JS files.

    Let us know if you still have any issue or need further assistance.

    Thank you.

    Thread Starter sray69


    Thank You! That appeared to have fixed the issue!

    Plugin Author Yoga


    You’re welcome!
    If you have any more questions or require further assistance, don’t hesitate to reach out. We’re here to help.

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Tabs Block – Tab content only visible to logged in users’ is closed to new replies.