Support » Plugin: Tabby Responsive Tabs » Tabs are not working

  • Resolved margaretconnelly

    (@margaretconnelly)


    The Tabs are not working. There should be 6 tabs across the top and they are not showing up. I’m running WordPress 5.1.1 with a custom theme. All plugins are up to date. This problem started about 2 weeks ago, but seemed intermittent. It only occurs when Not logged into WordPress (which I usually am, so I didn’t see it right away). I tried disabling all non-essential plugins, but that did not solve the problem.

    We are getting the console error
    (index):996 Uncaught ReferenceError: RESPONSIVEUI is not defined
    at HTMLDocument.<anonymous> ((index):996)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at Function.ready (jquery.js?ver=1.12.4:2)
    at HTMLDocument.K (jquery.js?ver=1.12.4:2)

    Any and all advice on how to solve this would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author cubecolour

    (@numeeja)

    It looks like the tabby.js & tabby.css files have not been included on the page. Issues like this are usually caused by a caching plugin & as I can see the line in your page source <!--Generated by Endurance Page Cache-->, I would suspect that the endurance page cache is preventing the css & js files from loading correctly.

    margaretconnelly

    (@margaretconnelly)

    Thank you for your quick reply. We are investigating now and I’ll post what we find.

    margaretconnelly

    (@margaretconnelly)

    We disabled the Endurance Page Cache plugin and that did the trick! Thank you again for your help with thie.

    The tabs are back! We now need to find a compatible caching plugin. Can you recommend any that you know work with Tabby Responsive Tabs?

    Plugin Author cubecolour

    (@numeeja)

    I do not have a specific recommendation for a cache plugin. I would suggest you try to continue using the existing cache plugin but request help from that plugin’s support team to solve the issue. Some cache plugins have functions to minify and combine css and js files and where this causes issues the plugin can be configured so that certain files are excluded from being affected.

    When we originally build our website, the commercial hosting service installed the cache plugin – without our knowledge! We have since moved the site to our own servers.

    But I did find a review of different cache plugins to choose from. https://www.isitwp.com/best-wordpress-caching-plugins-compared/

    I really appreciate your help with this!

    Hi there,
    I have a similar situation with my website. The tabs were initially working until I updated WordPress today. I have turned off all caching plugins but tabs still not working. You can have a look here: https://www.samplelogic.com/products/xosphere-2/
    Section under the SoundCloud area is where the tabs should appear.
    Any ideas what could have gone wrong?
    Thanks!

    Plugin Author cubecolour

    (@numeeja)

    You should have started a new topic as this one is set to resolved. Your tabby css & js files are loaded as expected however the js does not appear to be processed by your browser so there is probably a problem with another script that runs before tabby.js. If you updated plugins it is likely that one of them has a script which is broken & prevents tabby.js running. If you also updated your theme there could be a problem with a script loaded by the theme. Use the Health Check & Troubleshooting plugin to investigate which plugin (or the theme) is causing this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Tabs are not working’ is closed to new replies.