Support » Requests and Feedback » tables wrong in IE

Viewing 1 replies (of 1 total)
  • First, to make sure our terminology is straight, the default theme in WordPress does not use tables but rather div tags formatted through css to create columns.

    Now, what you’re seeing is due to the images appearing on your blog, some of which are wider than the post entry fixed-width column in the default theme. Why you don’t have a problem in Firefox is, the theme limits the ‘max-width’ property for img tags in its style.css. This property is not supported in IE6.

    A way around this is to hide the overflow of a post entry’s content, so when an image is wider it will be cut off — in a sense placed under or hidden beneath the right-hand column. You can do this by adding the following declaration to the theme’s style.css:

    .entry p {
    width: 100%;
    overflow: hidden;

    Other options: Make sure images displayed on your blog are not wider than the width of the content area; install a theme which does not make use of a fixed-width content column.

Viewing 1 replies (of 1 total)
  • The topic ‘tables wrong in IE’ is closed to new replies.