Support » Networking WordPress » Tables for new sites are NOT being created in the database

  • I created a new multisite installation with the latest 4.2.1 package downloaded from wordpress.org.
    When I try to add a new site to the network, it says the site is added, but when I try to reach the new site, it gives the error “Error establishing a database connection”. When I check the database, I see that the tables for the new site are not created (wp_2_, wp_3_, …).
    Afterwards, I erased the installation, dumped the database, downloaded a translation in my native language, and tried another fresh install, but it turned out the same.
    Then, I erased again everything, dumped the database, and this time made a fresh install with a 4.1 package. This one worked with no problems at all. I created some new sites, and there was no problem at all. The database looks like it should.
    Is there anyone else, facing problems with multisite in 4.2.1?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Does the SQL account you use have access to create new tables on that database?

    Yes, it does. It already created the base tables (by base tables, I mean the first tables created starting with wp_) and there were no errors. Besides, I installed an older version of WP (4.1.4). With that installation (same database, same user) no problems exist at all, it creates all the tables for the base site, and all other network sites.
    I haven’t tried to add a new site to an existing installation though, to the ones which newly got automatically updated to 4.2.1.

    I too had this issue, I installed 4.1.5 and instantly worked creating the tables (just as it says on the box)…

    I use a cPanel/WHM 11.48.4(b2) server on CentOS 6.6
    All DB information correct and tried with 4.2.1 multiple times to do multisite, did same process (as memorised it by then) with 4.1.5 works perfectly!

    4.2.2 doesn’t show any fixing of this issue, so I am hesitant to update and break it all… Anyone have anything further on this?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    The only (heh) DB change to 4.2.x is the change from utf8 to utf8mb4

    What version of MySQL?

    5.5.41 running on Debian Linux

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Tables for new sites are NOT being created in the database’ is closed to new replies.