Support » Localhost Installs » Tables are not created on installing WP on USB stick with XAMPP

  • Novice999


    Tried to install WP 3.4.2 on a USB drive with XAMPP lite 1.8.1. At the last step of the process I got the message that the DB needed repairing. Next I edited the wp-config.php so as to give permission for the DB being repaired, as requested. Trying the final installation step once again, I got the message that the DB needed repair, once more, and I was offered alternatives of “repairing” or “repairing and optimizing” the DB. After trying that, I got the following set of messages:

    wp_posts: Table ‘wordpress.wp_posts’ doesn’t exist
    wp_comments: Table ‘wordpress.wp_comments’ doesn’t exist
    wp_links: Table ‘wordpress.wp_links’ doesn’t exist
    wp_options: Table ‘wordpress.wp_options’ doesn’t exist
    wp_postmeta: Table ‘wordpress.wp_postmeta’ doesn’t exist
    wp_term_relationships: Table ‘wordpress.wp_term_relationships’ doesn’t exist
    wp_commentmeta: Table ‘wordpress.wp_commentmeta’ doesn’t exist,

    and I was told to copy and paste these messages to this forum, as I am doing now. So,I would aprreciate very much if anyone would give any hints.

    P.S.: I have a working copy of WP 3.4.1 installed on a USB drive with XAMPP 1.7.1.

Viewing 9 replies - 1 through 9 (of 9 total)
  • ricardusexa


    – First, try contacting the hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, if the hosting package is set to Windows and not Linux, etc .

    – double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

    -Then check that you don’t need to change the database host from “localhost” to something else. You can get that info from your hosting provider.

    -Check you have actually created a database with the same database name as is in your wp-config.php file.
    -Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider.



    I am affraid I did not make myself understood. I am installing WordPress to run locally on a pendrive with XAMPP. That is a nice and safe way to develop a site before you go out to the web. You do not even need a hosting provider to be able to do that.

    See, for example:

    1. How to Run WordPress on Your Windows Computer Using XAMPP — Part 1 of 2
    2. How to Run WordPress on Your Windows Computer Using XAMPP — Part 2 of 2

    After you have the thing functioning, you can even make a local copy of a remote site to run on the pendrive.

    See for instance:

    3. How to Copy Your Online WordPress Blog to XAMPP on Your Local Computer or USB Drive

    The problem is that at the end of part 2 of 2, the installation process does not finish: it just freezes.

    I mentioned that I have managed to take those three steps with WP 3.4.1 and XAMPP 1.7.1, but cannot do it with WP 3.4.2 and XAMPP 1.8.1 the most recent version of both programs.

    Thank you very for your interest. I Hope you or any one else can help me.



    The best thing would be make sure that the right script is running for the XAMPP install. Also, is XAMPP 1.8.1 a beta program? Did you have any success using XAMPP 1.7.1 to install WP 3.4.2? Those would be the different things that I would try.

    Since you are on windows, there is an alternative that you can use to XAMPP which is WAMP. I am not sure if it works on a USB drive but it is another server you can use for local development.



    Hi, Jv8080:
    1. instead of installing WP 3.2.1 on XAMPP 1.8.1, I updated the WP 3.4.1 (the one I mentioned I had running on XAMPP 1.7.1) to WP 3.4.2.
    I must say that I could not find the time to verify the whole site, but I think it is running fine.

    2. I fear that the WAMP alternative suggested is not exactly what I am looking for (have the most recent version of each software working together) given that it is kind of very old (2003, or so).

    3. XAMPP 1.8.1 is not a beta version.

    4. I know nothing abou scripts (the other thing you suggested I should try). I would be very thankful if you would let me know where to go to get some information about it.

    Thank you so much for your assistance.

    PS.: if you would like to have a look at the on-line site, the URL address is www[dot]fce[dot]uerj[dot]br



    Hi Novice999,

    Looking through the XAMPP forums, I am thinking that this is the problem that you are having with your XAMPP 1.8.1 install. If you read that, you will find that there was somewhat of a mistake in telling people to install a program without installing the needed compiler add-on. Making a long story short, you need to go get Microsoft’s Visual C++ runtime library and install it.

    As for the scripts, I was just wondering if the scripts that you were running were out of date and not communicating with WordPress but that is not a the case thinking about it since you are running recent versions of XAMPP.

    As for your live site, I see that you have 3.4.2 running so it is a good idea to keep your local and live WordPress sites in sync.

    The error that you were getting is a connection issue such as the ones mentioned by ricardusexa. Let me know if 1.8.1 works with the Visual C++ add-on.



    Hi jv8080,
    Unfortunately the Visual C++ did not help WP342 + Xampp181 work from the pendrive; however, moving the install to the root of C: (the HDD) it did! But this is something I had not done before, so I do not known for sure it would not have worked without VC++. If it did, how would I have known VC++ was not there in the first place?
    Anyway, the doubt persists: can the couple WP342 + X181 live together?
    Thank you for your time once again.



    No problem. I’m glad you got everything working even though it was not exactly how you wanted it to end up. If I test it and have any success, I will drop you a line.

    Good luck with your project…jv8080.



    Hi jv8080
    What I did was the install of WP 342 and X 181 on the root of HDD and, since it was functional, I copied it back to a USB flash driver. This copy did function too. I have yet to triy making the copy of the remote site onto either of the installs (that is, on C: and USB drv). That is what I am going to do next. I will let you know whatever the outcome is.
    Thank you.

    Hi jv8080 and everybody else,
    I managed to get the WP 342 working with X 171 through the three-step procedure given by the above mentioned links. I also managed to have WP 342 working with X 181, but just for the two first steps.
    Everything seems fine till the end of step three (including the successful import of the remote database), but when I browsing the site, I get the first page ok. However, any option in the menu leads to the 500 error (that might be either the overload of the apache server or something related to the CGI scripts). So, the problem is still hard to solve.
    There is a complaint about an URL not found, as well.
    It does not seem to be a problem with the site since the WP 342 + X 171 combo works fine.
    I do not know what to do next.
    Any more hints?
    Thank you in advance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Tables are not created on installing WP on USB stick with XAMPP’ is closed to new replies.