Support » Plugin: TablePress » TablePress Caching problem with NextGEN Gallery >> Invalid shortcode

  • Resolved Thomas

    (@thomast)


    Hi Tobias,
    when I use the NextGEN Gallery shortcode [ngg_images image_ids="1291" display_type="photocrati-nextgen_basic_singlepic" ] in a TablePress cell, I get a “Invalid shortcode” text instead of the image tag generated.
    This problem could only be reproduced when I’m not logged into WordPress. When I update/save my table I could only once see a correct image, after I reload the page I got the “Invalid shotcode” text.
    After some research, I found the workaround to disable the caching for this dedicated table to fix my problem.
    [table id=6 cache_table_output=false /]
    But in general, I guess it is a caching bug which should be fixed in TablePress.
    Regards
    Thomas

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    This is not actually a bug in the caching. It’s more that the Shortcode is not evaluated again as the cached values are loaded. Depending on how the other plugin does things, this might however mean that things like JavaScript is not loaded.
    Turning off the caching is the best solution then.

    Now, having said that, putting a gallery into a table sounds wrong, as tables shouldn’t be used for styling purposes, but only to present tabular data.

    Regards,
    Tobias

    Hi Tobias,
    thank you for your fast response. The NextGEN Gallery plugin generates a div element with a link and a small thumbnail. If JavaScript is involved, I did not know.
    I use in my table not a gallery, I used a single thumbnail to present to each name a picture of the person.
    So, I leave the cache disabled, but this was not required in the past.
    Regards
    Thomas

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    ah, ok, it sounded like you are using a gallery. Thumbnails are of course fine. (Galleries are fine, too, it’s just not optimal.)

    From TablePress point of view, turning off the cache in such situations was always necessary. I assume that NextGEN mabye changed some behavior that made this necessary now. Good to hear that everything is working now 🙂

    Best wishes,
    Tobias

    Where do we enter the code:
    [table id=5 cache_table_output=false /]

    “extra css classes” window?

    Thanks

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    you would put this into the post or page where you want to show the table. You should have the shorter version [table id=5 /] there right now. That’s what you have to extend with that parameter.

    Regards,
    Tobias

    Thank you Thomas and Tobias. I had identical behavior using NextGen
    and Foo Gallery with Table Press also. The code Thomas provided works fine.

    I have used Table Press + Next Gen for years on an installation,
    and like Thomas, did not have this issue until recently.

    A while back, I noticed a Lite Speed plugin had appeared and I could not
    recall installing it. Similar to what was reported here:

    https://wordpress.org/support/topic/litespeed-plugin-uploaded-wo-permission/

    The hosting uses Lite Speed Web Server, but I don’t know for how long.
    Wordfence reported that LSWS can halt some functions if they take more than
    a few moments to complete, and I do not know if that might include loading
    a gallery into a table, or if it could lead to the problem Thomas and I experienced.

    https://forums.stablehost.com/index.php?threads/trouble-with-wordfence-and-litespeed.478/

    Apologies if this info is off base- offering it up in case it helps.

    Thanks Again

    Ray

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    good to hear that you got it to work.

    That Lightspeed issue is something completely different, it has nothing to do with this issue, from what I can see.

    Best wishes,
    Tobias

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘TablePress Caching problem with NextGEN Gallery >> Invalid shortcode’ is closed to new replies.