Support » Plugin: TablePress » TablePress button suddenly missing from Admin menu also

  • Resolved abinterfaces

    (@abinterfaces)


    I cannot for the life of me figure out how to get the TablePress button to show back up in my admin menu. It used to. I’m not sure when it disappeared but I did recently install the “user role editor” plugin. I’ve disabled and re-enabled every combination of it and yours that I can think of to no avail.

    Any thoughts?

    Thanks in advance!

    http://wordpress.org/extend/plugins/tablepress/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble. This likely means that the “User role editor” plugin stripped the necessary capabilities from your user role.

    If you want, I can try to restore these on your site, with a custom debug plugin I have for this. In order to do that, please send me an email (the address is in the main plugin file “tablepress.php”) with details to a temporary admin account. Thanks.

    Regards,
    Tobias

    Email sent. Thank you so much!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    just for everybody following this thread:
    I’ve worked directly on this with abinterfaces, and we were able to directly fix this on his site, by restoring the access capabilities for TablePress.

    Regards,
    Tobias

    You’re the man. Thank you for the fix and for what you do. You plugin developers allow us to have functionality that we couldn’t otherwise and it directly affects our incomes. So again… thanks!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    sure, no problem, you are very welcome!

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

    I have the exact same issue.

    What I have ssen, is that direct after installation (1 day ago) of User Role Editor, the Tablepress capabilites are shown in the Role Editor as extra box for Tablepress. But today, this disappears as also the Tablepress Button in the dashboard.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    sorry to hear that you are also suffering from this.
    That’s a weird issue then. My only explanation is that User Role Editor then somehow resets the capabilities to the WordPress defaults. And when those are missing, the admin menu entry is not added.

    I can make the same offer as above:
    If you want, I can try to restore these on your site, with a custom debug plugin I have for this. In order to do that, please send me an email (the address is in the main plugin file “tablepress.php”) with details to a temporary admin account. Thanks.

    Regards,
    Tobias

    Tobias,

    thanks for the quick response.

    We solved it with removal of User Role Editor and a restore of the database from a backup.

    Anyway, this should be solved somehow, since we would like to use both of this plugins.

    Best Jens

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi Jens,

    good to hear that you were able to fix it.
    As I said above, this is more likely to be a temporary problem in User Role Editor.
    There’s nothing really that I can change in TablePress here. TablePress (when it is activated) adds the initial access capabilities to WordPress. In your case, User Role Editor then somehow removes these again, maybe on accident when someone edited the capabilities.

    There’s usually no problem in using User Role Editor and TablePress together, and many people do it. One just has to be careful to not accidentally remove the TablePress capabilities from a user role.
    (I personally use the “Members” plugin for such operations, by the way, which also has nice user role component.)

    Regards,
    Tobias

    Tobias,

    you are talking about this one here:

    http://wordpress.org/extend/plugins/members/

    Gruß Jens

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi Jens,

    yes, that’s the one that I was refering to.

    Best wishes,
    Tobias

    Blast!
    I just had the same issue. For me I was able to recreate by hitting the clear button on the user_role_editor interface.
    I was able to fix by restoring a backup of the wp_options table only. A full backup was not required. I have never used user_role_editor before and it was installed by a previous developer. I plan to ween my client onto wp_members as you suggest. I have never had a conflict with wp_members that I remember.

    Your plugin rocks though! I certainly helped you to keep that 5 star rating you deserve.

    Ich danke Ihnen sehr!
    ____Chris

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi Chris,

    good to hear that you were able to fix this by clearing those roles! Switching to “Members” should indeed be the best way to go here, as that seems to be more robust.

    And thanks for wanting to rate TablePress, I really appreciate it!

    Best wishes,
    Tobias

    Hey,

    Thanks for the great plugin. I am currently having the same issue. I installed User Role Editor after I installed TablePress 0.9RC. Although, I haven’t used URE at all, TablePress tab disappeared from the admin menu. I, unfortunately, cannot send you any link as I am working behind a proxy before the website goes live.

    Is there any other way of solving this problem? I have tired using Admin Menu Editor but that does not solve my problem either.

    Thank you very much in advance.

    Cheers,
    Mustafa

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    My assumption is that User Role Editor reset all the capabilities. To fix this, please check in URE, whether the user roles that you use, possess the relevant TablePress capabilities. Their names all start with a name like “tablepress_”.

    Regards,
    Tobias

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘TablePress button suddenly missing from Admin menu also’ is closed to new replies.