Support » Plugin: TablePress » table_info last_modified not working

  • Resolved w8tts

    (@w8tts)


    We use the last_modified option of table_info on every page that has a table to show when the table was last update. But, it doesn’t always work.

    Our standard entry is:
    <h6>Table last modified at [table-info id=11 field="last_modified" format="date time" /] UTC</h6>

    We’re running Version 1.9.2 of TablePress
    And WordPress 5.2.2

    Any thought why it isn’t working?

    Ted

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    "date time" is not a valid value for the format parameter. Can you maybe try with a different one, like just date or just time? If you want both, you’d need to split them into two Shortcodes.

    Regards,
    Tobias

    Thanks, Tobias.

    I got digging deeper and found that it appears that the “date time” that I use in the format parameter works as I get this “Table last modified at August 28, 2019 2:53 pm UTC” when I use
    <h6>Table last modified at [table-info id=11 field="last_modified" format="date time" /] UTC</h6>

    It appears that when our pages were built that the wrong table ID was placed in the “id=” parameter.

    Back to editing 60+ pages.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    yes, the value will produce an output, but it’s basically the fallback, which is the same that should be produced by the value mysql.

    Sorry to hear that you’ll have to fix all those table IDs now. 🙁

    Regards,
    Tobias

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.