WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Table ‘wp_post2cat’ doesn’t exist

[Resolved] Table ‘wp_post2cat’ doesn’t exist

  • BLT-FQX

    @blt-fqx

    Error message in the home page.

    WordPress database error: [Table ‘wp_post2cat’ doesn’t exist]
    SELECT p2c.category_id AS cat_id, COUNT(p2c.rel_id) AS numposts, UNIX_TIMESTAMP(max(posts.post_date_gmt)) + ‘8’ AS last_post_date, UNIX_TIMESTAMP(max(posts.post_date_gmt)) AS last_post_date_gmt FROM wp_post2cat p2c INNER JOIN wp_posts posts ON p2c.post_id=posts.id WHERE 1 = 1 AND posts.post_type = ‘post’ AND posts.post_status = ‘publish’ AND posts.post_date_gmt <= ‘2007-09-19 12:08:25’ GROUP BY p2c.category_id ORDER BY numposts DESC

Viewing 15 replies - 16 through 30 (of 36 total)
  • stribe37

    @stribe37

    I upgraded to WP 2.3 with no problems at all. I only saw this error when I got the Simple Tagging plug-in and activated it. When I de-activated it, the error disappeared. I’d like to use Simple Tagging, but not if it’s going to give me that error. Any way to fix it?

    Keilya

    @fantasycrusader

    I’m afraid not as the plugin is currently not compatible with WP 2.3. Guess you could search for another tagging plugin or use the new one that comes with 2.3

    Or wait for the author to release a new version. (:

    Oh I see. I just spent almost 4 hours scratching my head and asking myself why the current Simple Tagging plugin (1.7) still doesn’t work. I thought it was already fixed since the one posted in the Known Issues section only mentioned of the Release Candidate version of WordPress 2.3, not the Final (which was just released).

    I use the same function of Simple Tagging that BLT-FQX uses (Related Posts). I also had the same results with stribe37. I guess I’ll just have to wait for an update and disable the plugin for a while.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Virtually no tagging plugins will be compatible with 2.3 yet. Same thing goes for plugins that deal with categories in any way.

    2.3 is new. Wait for things to settle down. Or don’t upgrade to 2.3 yet. Nobody said that you have to do it first day.

    stribe37

    @stribe37

    fantasycrusader said:

    Guess you could search for another tagging plugin or use the new one that comes with 2.3

    I’m wondering how exactly to use the tagging function in 2.3. I see the tag input box below where I write my post.. but anything I put in there doesn’t show up at all as a tag when I publish and post something.

    Geezerjim

    @actorjiml

    Check the codex here, and here.

    Jeremy Clark

    @jeremyclark13

    Member

    Your theme has to be updated to display the tags. If you feel confident enough you could update it your self with this.

    Also if you want to create a tag archive page have a look here.

    stribe37

    @stribe37

    Thanks for the suggestions. I added the simple line in the Main Index Template, and it works fine now for showing those tags up. I think I’ll wait a bit on the tag cloud.

    10cplay

    @10cplay

    I’m getting the same error message when I either post a new post, or add a comment. It doesn’t seem to affect the posting or the comments being added though.

    I didn’t do my own code and don’t see any advice on which bits of code to alter and in which files…

    I don’t have a tagger plugin…

    Any tips peeps?

    site located at 10cplay.com

    10cplay

    @10cplay

    Bingo…

    Apparently the Google Sitmaps plugin needed an update…

    I try to keep relatively plugin free, but this one is sooooo essential.

    Thank you!

    I had a error like the OP while upgrading today. As it turned out, I had uploaded the wrong wp-config.php file (I look after 4 WP istalls.) After replacing with the correct one and a database (re)upgrade, everything’s fine.

    nhtahoe

    @nhtahoe

    The “Posts by Author” plugin was causing this problem for me after upgrading to 2.3. I deactivated it and now everything is fine. Pretty frustrating though!

    Brooklyn2

    @brooklyn2

    Table ‘wp_post2cat’ doesn’t exist

    I also received the above error message. I was so convinced that I had done something wrong with permissions or something like that, that I deleted my site, deleted my database, and completely uploaded a new and clean WP 2.3, only to find out I was getting the same error. later found out that the error came from plugin “Google Sitemap” I deleted the 2.7 Google sitemap, then I was no longer getting the posting error. Tried to upload the Google Sitemap 3.0. Could not upload Newer Version of Google sitemap, using WSFTP. So as of now I am able to post without getting that error message, but I have no Google Sitemap, Now that is a bummer.

    Forgotten1

    @forgotten1

    My issue with this was stemming directly from the Google Sitemaps 2.7.1 plugin. I thoroughly tested each of my plugins one at a time until I found the culprit. Once disabled, no more errors were discovered.

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘[Resolved] Table ‘wp_post2cat’ doesn’t exist’ is closed to new replies.