Support » Plugin: TablePress » Table not showing on https page

  • Resolved Mike1984

    (@mike1984)


    TablePress isn’t working on my https pages. Works fine on http pages. Normally I wouldn’t care as I always link the non secure version, but Google has started showing the https pages of my site in the SERPS for some reason. What could cause the tables to not display on https pages?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your question, and sorry for the trouble.

    Can you explain what exactly is not working on the https:// site? TablePress does not contain features that depend on the scheme…
    Can you please post a link to the page with the table where this problem happens, so that I can take a direct look? Thanks!

    Regards,
    Tobias

    For now I found a solution by just 301 redirecting the https URL to the http version, but the page is: http://www.mechtype.com/mechanical-keyboard-list/ (with https of course, don’t want to give Google more reason to show the non-http version).

    On the https version it was just displaying the insertion text as it looks in the WordPress backend with: [table id=1 /] It can be seen in the Google cache of the page, until they recrawl it anyway.

    Thanks.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    that doesn’t make sense. Are you using any special plugin to get https:// support? Are you maybe using caching on one page, but not on the other? Are these the same WordPress installations?

    Regards,
    Tobias

    No special plugin. I wasn’t even aware I had functional https support until the URL’s started showing up in Google. Seems like this is something my hosting provider includes for free and is setup automatically. I assume anyway, because I never purchased an SSL certificate. I do have caching plugins installed (Comet Cache, Autoptimize), but made sure to clear and disable them while testing. Yes, only one WordPress install.

    Ok, problem solved. I’m an idiot. I use a plugin called Plugin Organizer to disable plugins on pages they aren’t needed. It has a setting called “Ignore URL Protocol” that needed to be enabled. It was seeing the http and https as two different posts, which caused it to not enable TablePress for the https URL.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    ah, that makes sense then! 🙂 Good to hear that you found that cause.
    And thanks for sharing that! I’ll hopefully remember this in case I happen to see this issue again.

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Table not showing on https page’ is closed to new replies.