Support » Plugin: NewStatPress » Table is missing

  • Resolved thenicnic

    (@thenicnic)


    Hello,

    I’m very glad that there is this (apparently) very good plugin. Thank you that much! Unfortunately it does not work on my page, there isn’t even a created table; the Update feature puts out:
    [Table ‘DB29xxx.wp_statpress’ doesn’t exist]

    I tried Remove, Repair and even reinstall the plugin (from direct download and from repository) but there is still no table – so the widget and the Details area are not showing any visitors 🙁

    I’m using the SportsPress theme and a customzied .htaccess and I thought the last one is causing the trouble, but nope – the problem residents also with the default one.

    Is there anybody out there who may help me?

    Best regards,

    Nico

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • thenicnic

    (@thenicnic)

    Hi,

    problem solved. The SQL query generated in your PHP was:

    CREATE TABLE wp_statpress ( id mediumint(9) NOT NULL AUTO_INCREMENT, date int(8), time time, ip varchar(39), urlrequested varchar(250), agent varchar(250), referrer varchar(512), search varchar(250), nation varchar(2), os varchar(30), browser varchar(32), searchengine varchar(16), spider varchar(32), feed varchar(8), user varchar(16), timestamp timestamp DEFAULT 0, UNIQUE KEY id (id), INDEX spider_nation (spider, nation), INDEX ip_date (ip, date), INDEX agent (agent), INDEX search (search), INDEX referrer (referrer), INDEX feed_spider_os (feed, spider, os), INDEX os (os), INDEX date_feed_spider (date, feed, spider), INDEX feed_spider_browser (feed, spider, browser), INDEX browser (browser)) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_520_ci;

    which ended up in

    Query error: Index column size too large. The maximum column size is 767 bytes.

    That’s why I added ROW_FORMAT=DYNAMIC in the PHP code (at the end of the query):

    $sql_createtable.=") $charset_collate ROW_FORMAT=DYNAMIC;";

    Works like a charme.

    Hint: Problem occured while using InnoDB at STRATO webspace (German webhoster).

    Plugin Author ice00

    (@ice00)

    hi,

    thanks for the report.
    Actually my servers did not uses InnoDB, so the problem was not popped up before

    Bonjour, 2 jours que je cherche pourquoi Newstatpress ne fonctionne pas. HĂ© bien je ne suis pas sur, mais aprĂ©s lecture de ce post, je suis allĂ© voir ma base de donnĂ©e, et il n’y a pas de tables statpress et pourtant quand je fais mise Ă  jour dans les options newstatpress, il me dit que tout va bien et que les tables structure statpress et index statpress et les reste sont bien cochĂ©es en vert.
    Sous PHP My Admin les tables sont de type InnoDB. est ce que cela vient de lĂ ?
    J’ai dĂ©ja dĂ©sisntaller plusieurs fois, mais rien n’y fait. toujours pas de tables sous Php My Admin.
    Je suis pas aussi douĂ© que Thenicnic, alors j’ose pas trop tripoter la base de donnĂ©e.
    Est ce qu’il y a une autre solution?
    Merci pour vos réponses.

    Michel

    Super,Thenicnic, j’ai osĂ© le faire et ça fonctionne.
    Grand merci Ă  toi d’avoir partagĂ© la solution.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Table is missing’ is closed to new replies.