WordPress.org

Support

Support » Plugins and Hacks » amr ical events lists » [Resolved] table css broken?

[Resolved] table css broken?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author anmari

    @anmari

    Hmmm… Sure seems like it…. Maybe I have something wonky in my configuration?

    Site is http://thecatbirds.net/dates

    Happy to give you any more info you need!

    – Fred.

    Plugin Author anmari

    @anmari

    Hi Fred, sorry things got bit hectic here.

    I finally tracked it down to where the code allows for multiple shortcodes on a page (Have to have different id’s then, else html will not validate. )

    Code will add a number to the id, if it detects that it is NOT the first use of the shortcode. So somehow it thinks that that instance of the shortcoe that you have is NOT the first time the shortcode has been used. (Because the global amr_icalno has been set). So on my pages there are no numbers in the div id because the shortcode is either the first or the only one on the page.

    See
    line 2045 in amr-ical-events-list-main.php

    function amr_get_id_for_shortcode () {  // allows for the possibility of multiple shortcodes in one page.
    global $amr_icalno;
    
    	if (!(isset($amr_icalno))) $amr_icalno = 0;
    	else $amr_icalno= $amr_icalno + 1;
    
    	if ($amr_icalno	== 0) $idnum= '';
    	else $idnum = $amr_icalno;
    	$id = ' id="events_wrap'.$idnum.'" ';
    
    	return ($id);
    }

    Do you have custom code anywhere ?

    Hmmm … I don’t think I have custom code anywhere. I am using a custom format, but used the plugin to create it.

    The shortcode I use on the page is:
    [iCal ics=”http://chandlertravis.com/?gigs_calendar_ical&event=catbirds” listtype=”14″]

    And that’s it for page data.

    And I don’t see another occurrence of “event-wrap” anywhere in the page source (http://thecatbirds.net/dates/) other than in <div id="event-wrap1" > around my events.

    Weird – anything you can think of for me to look at/for?

    (oh, and no problem with lag between messages – for one, I’ve been under the weather, but also I have the workaround of adding event-wrap1 to my CSS)

    Thanks!

    – Fred.

    Well … it seems to have “fixed” itself somehow! I wonder if it was a theme or plugin compatibility issue.

    Sorry about this!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] table css broken?’ is closed to new replies.
Skip to toolbar