Support » Plugin: TablePress » Table Cells Are Empty

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your question, and sorry for the trouble.

    This is indeed interesting. I’m not really sure what could be causing this. Are you maybe using a custom plugin (or code in your theme) that does something with the table data?
    I can for example imagine that a filter hook on the tablepress_cell_content filter is not properly returning a value.

    Regards,
    Tobias

    Hi Tobias–
    Thanks for your suggestion. That was exactly it. I had built a very simple functionality plugin to allow Quick LaTeX code to be included in TablePress cells: https://github.com/SteelWagstaff/tablePress-LaTeX/blob/master/tablepress-latex.php but we didn’t have the WP Quick LaTeX plugin network activated. If my functionality plugin was active but not the Quick LaTeX plugin, then the tablepress_cell_content filter wasn’t properly returning a value, as you suspected. I think I need to add a check for WP Quick LaTeX activation to the functionality plugin to avoid this problem in the future. Appreciate your timely response!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    no problem, you are very welcome! 🙂 Good to hear that this helped!

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Table Cells Are Empty’ is closed to new replies.