Support » Plugin: National Weather Service Alerts » Table build on local WAMP environment

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author John Russell

    (@laubsterboy)

    It shouldn’t be a problem, since I develop the plugin on a local LAMP environment, but there are a couple things that come to mind.

    • The WordPress DB_USER (user account in MySQL) doesn’t have the CREATE privilege.
    • There’s a possible WordPress Ajax url issue (bug in the plugin) that won’t work properly if you’re using http://localhost rather than http://127.0.0.1. This is just a theory as I’ve only tested it with http://127.0.0.1.
    • Another plugin (or the theme) may be causing a JavaScript error and breaking the ability to call to build the tables

    Would you be able to set the theme to one of the WordPress default themes (twentyfourteen for example) and then deactivate other plugins, and then enable WordPress Debugging? Let me know if anything is showing up in the debug.log file. Once that’s enabled try building the tables again and see if there is anything in the debug.log file (should be in the wp-content folder). If that’s empty, there is a chance it’s a JavaScript error and that should be visible if you use Google Chrome and press CTRL (Command) + Shift + I to open the developer tools and view the Console. With the console open try building the tables again and if there is a JavaScript error it will show up in the console.

    What sort of behavior are you seeing when trying to build the tables? Is it just unresponsive?

    Any additional details that you can provide will be very helpful.

    I am using localhost and I was already using one of the default themes. I have tried enabling debugging and I can’t even get anything to work there. I set it to true and no file was created. And added WP_DEBUG_LOG and I get no file showing up.

    I also tried deactivating everything but this plugin. It’s just unresponsive. THe button grays out for a few minutes, there appears to be no progress bar, and then after a couple of minutes the button is no longer grayed out. But it still says tables aren’t created.

    Plugin Author John Russell

    (@laubsterboy)

    Are you able to install new plugins (or themes) in the Dashboard using Plugins > Add new > Install (directly from the WordPress Plugin Repository)? Or, do you have to use “Upload Plugin” or manually add the plugin to your /wp-content/plugins/ directory? I ask because it’s possible that WordPress doesn’t have filesystem access to make changes to the wp-content directory and file permissions may be causing problems. If you’re able to install plugins via Add New > Install and they install without problems then permissions are likely fine.

    So long as WP_DEBUG and WP_DEBUG_LOG are both set to TRUE there are really only two reasons a debug.log file is not showing up:

    1. File permissions are preventing WordPress from creating the file so the user that Apache/PHP runs as does not have write access to the wp-content directory.
    2. The other possibility is that there is no debug.log file because there were no errors so WordPress didn’t need to create the file, yet.

    If you think file permissions are good and WP_DEBUG and WP_DEBUG_LOG are set then I recommend deactivating NWS Alerts and clicking “Delete”, from the plugins screen (which will run the uninstall file), so that it’s completely cleared out (options, transients, and DB tables), and then try installing again.

    I can install from the repository just fine. And pull in rss feeds just fine.

    I uninstalled NWS and reinstalled it. Still getting the exact same result

    Plugin Author John Russell

    (@laubsterboy)

    There is a chance it’s bug within the plugin due to Windows, since I’ve personally only tested it on linux/mac. At this point I’m out of ideas, unless you’re able to get it to output some sort of error (in either debug.log or Chrome developer tools).

    I’ll try to test it on a Windows box soon, though it will likely be several days.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Table build on local WAMP environment’ is closed to new replies.