• Resolved sunnyhova

    (@sunnyhova)


    I love the Advanced Gutenberg plugin, especially the Advanced Table block. But I’m always having this problem with it.
    Whenever I create a new table, add data and save, when next I want to edit the page, I usually encounter this error, THIS BLOCK HAS ENCOUNTERED AN ERROR AND CANNOT BE PREVIEWED.
    I always have this problem with this Advanced Table block.
    Why is this always happening? I really love this block because it is quite useful as I always need to create data tables in Gutenberg, and it is like the only solution that works straight off the bat in the block editor.

    Please what should I do?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author advancedgutenberg

    (@advancedgutenberg)

    Hi @sunnyhova,
    we appreciate your kind words!

    The editing process works fine in my end. May you share step by step details to reach the issue?

    Important: please be sure you are using the last version of Advanced Gutenberg: 2.3.9
    ____
    Regards

    Plugin Author stevejburge

    (@stevejburge)

    Hi @sunnyhova

    We’ve not been able to re-create this in testing.

    Can you use the “Support” link on https://advancedgutenberg.com to send us more details of your site?

    Choose “I’m reporting a bug” and it will ask for the info.

    Advanced Gutenberg version: 2.4.1
    WordPress version: 5.5
    After upgrading to WordPress 5.5 a table that is an Advanced Gutenberg table and frequently modified became uneditable. Other Advanced Gutenberg tables on the page could be edited.

    If the problematic table was followed by another table, they were grouped together as one block and only the second table cells could be changed. If a paragraph was after the problem table, the table appeared as part of the paragraph block and only the paragraph could be edited.

    Ran page through w3 code validator without issue. Checked html code and saw no issue.

    While experimenting an example minimal code to recreate the table issue is:

    
    <!-- wp:advgb/table {"changed":true,"align":"left"} -->
    <table class="wp-block-advgb-table alignleft advgb-table-frontend"><tbody><tr><td style="border-top-color:#000;border-right-color:#000;border-bottom-color:#000;border-left-color:#000">TEST 1</td></tr></tbody></table>
    <!-- /wp:advgb/table -->
    
    <!-- wp:paragraph -->
    <p>Test 2</p>
    <!-- /wp:paragraph -->
    

    To remove the issue I found changing the html code of the problem table to the following fixes the issue (Changing from left align to centre align fixed the issue):

    
    <!-- wp:advgb/table {"changed":true,"align":"center"} -->
    <table class="wp-block-advgb-table aligncenter advgb-table-frontend"><tbody><tr><td style="border-top-color:#000;border-right-color:#000;border-bottom-color:#000;border-left-color:#000">TEST 1</td></tr></tbody></table>
    <!-- /wp:advgb/table -->
    

    While editing the page in wp-admin, developer tools console is reporting errors: reloading editor by Advanced Gutenberg plugin (anonymous) @ editor.jsx:79
    and then going on to report all the core blocks are already registered
    blocks.min.js Block “core/paragraph” is already registered.

    `

    • This reply was modified 2 months, 2 weeks ago by okrogerthat.
    Plugin Support htmgarcia

    (@htmgarcia)

    Hi @okrogerthat,
    we just made a new release related to buggy blocks inside groups and columns in frontend. Please update and see if that solves the problem.

    If this issue is different, please share the most possible details through our contact page: https://advancedgutenberg.com/

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.