Support » Plugins and Hacks » Tabbed Widgets picky with 2.8?

  • Since I upgraded to WordPress 2.8 this morning, the plugin’s been picky with some widgets. It seems to hate text widgets, the calendar, archive…

    It’s also hating the disqus widget, which is just a text widget with js in it.

    Any fix in the works?

Viewing 15 replies - 16 through 30 (of 58 total)
  • I was going to make a donation for this widget when I started implementing it to v2.7 and when the site launches. But didn’t have a change to use it just yet as like many of you, I upgraded the site to v2.8 when it was still under development and the widget no longer works.

    This is a great widget, and obviously many of you who are waiting for the new release love to continue using it. Therefor, I would like to make a proposal that why don’t we each make a contribute to kasparsd, so that he can have the luxury to spare a bit of time to make this widget compatible with v2.8 sooner. I would have gone ahead sending a donation to kasparsd, but I don’t think my own effort help much to speed up the development–being a web designer myself, I know how much time it can take for a programming work like this, therefor I think it will be greatly helpful if all of you waiting for the widget can help pool up a fund.

    I was going to donate US$25 initially, but I am going to top it to US$40. Please join me everyone. And to kasparsd, if you see this message, can you tell us if this is workable for you to make the widget works in v2.8 sooner?

    thanks

    I have been working on this damn thing for over 2 weeks now. I have uploaded 4 different widgets using my Filezilla to my hostgator epanal and can’t find anything anywhere. I have not been able to get any widgets onto my blog. I started out with the 2.8 and after reading all of the other post, I’m about ready to dump this whole thing in the trash and go back to google blog. I have had to do all of my links as a post on my front page just so I could get it up to advertize with. I have lost over three weeks of advertizing in my marketing and only have a couple of weeks left before I lose everythine, I have been out of work for 5 weeks now and this was my last hope of bringing in some income. Is it possable to go back to the 2.6.3 like I was suppose to start with??

    alsd, this would sure help a lot. Every donation counts and moves things higher in the priority list.

    I also appreciate you encouraging others to support the development of this Free Software.

    wolverine7, with WordPress you don’t have to upload widgets to the server. Check the Appearance > Widgets section of your WordPress admin area.

    Hi, kasparsd. I sent 30 euro. I hope you have already received contribution from other who love to continue using this widget. 🙂

    Hi all! Somehow weird.. I don’t have problems in the frontend but on the site itself. Since WordPress 2.8 I can’t show tabs anymore (newest jquery used). I get the message:

    $.widget is not a function
    (?)()(function())ui.tabs....ver=1.7.1 (Linie 608)
    ui.tabs.js?ver=1.7.1()()ui.tabs....ver=1.7.1 (Linie 685)
    $tw(this).find(".tw-rotate .tw-nav-list").tabs is not a function
    [Break on this error] fx: { opacity: 'toggle', duration: 'fast' }

    So, no fix for 2.8 as of yet?

    Any updates on this?

    Looking forward for an update on this one 🙂

    Regards.

    The tabs issue is described here:

    http://comox.textdrive.com/pipermail/wp-hackers/2009-June/026680.html

    Essentially, for WP 2.8, where you used to have

    jQuery('#foo > ul').tabs();

    you now need

    jQuery('#foo').tabs();

    (provided you’re loading the jquery and ui.tabs that come with WordPress)

    Sorry, i didn’t get your solution. Could you explain it a bit more? how can we get this tabbed-widget plugin to work?

    Tosh

    (@xberserker)

    I came across this today. It’s the best looking one it seems. This would work perfect for me. On your fix Roger, I can’t find that code in the plugin.

    Roger’s post doesn’t mean anything. That’s just a small jQuery issue.

    The larger issue at hand with WP 2.8+ is the entire widget API has changed.

    So a lot of kaspars’ code will need to be rewritten in order for Tabbed Widgets to work on 2.8+.

    Hey kasparsd,

    Any ETA on the 2.8 version of Tabbed Widgets? Not upgrading to 2.8 until the update is available and tested. Thanks. You have an excellent plug-in.

    kasparsd!!!

    Please update this awesome plugin! We beg you! Pretty please!

Viewing 15 replies - 16 through 30 (of 58 total)
  • The topic ‘Tabbed Widgets picky with 2.8?’ is closed to new replies.