Support » Plugin: Carbon Fields » tabbed-vertical not allowing drag-n-drop

  • Resolved Sean T.

    (@tinothepro)


    Hi,

    I am trying to set up a complex field with the vertical tabs. The vertical tabs work but the drag-n-drop functionality to rearrange the tabs does not work. The horizontal tabs and the default layout both allow for rearranging. Please assist.

    Container::make(‘post_meta’, ‘Builder’)
    ->show_on_post_type(‘page’)
    ->add_fields(array(
    Field::make(‘complex’, ‘Sections’)
    ->setup_labels($section_labels)
    ->set_layout(‘tabbed-vertical’)
    ->add_fields(‘Content Section’, array(
    Field::make(‘text’, ‘content_section_text’, ‘Title’)

    ……(omitted the rest for lack of relevance)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Atanas Angelov

    (@atanasangelovdev)

    Hi @tinothepro,

    Did you try dragging the hamburger-like icon on the left end of the tabs (it’s not the most obvious thing) rather than the rest of the tab?

    Hi Atanas,

    I did yesterday and it was not working. I also noticed yesterday that the first item had 2 dashes in the hamburger where as the rest had 3. Wonder if this was why it wasn’t working? I tried this morning after reading your post and it works. Kind of puzzled on why this was as my whole team here at the office tried it yesterday. Maybe a bug that I can’t replicate again. Thank you so much for your help!

    Plugin Contributor Atanas Angelov

    (@atanasangelovdev)

    Happy to help 🙂

    (I’ve added a ticket to our internal todo to review why the tab is not draggable in it’s entirety so we will probably see that improvement in 2.0.)

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘tabbed-vertical not allowing drag-n-drop’ is closed to new replies.