WordPress.org

Support

Support » Installation » [Resolved] T_STRING error in feed.php

[Resolved] T_STRING error in feed.php

  • I am installing WP for the first time and when I go to /install.php I get this error:

    Parse error: syntax error, unexpected T_STRING in /home/content/t/o/d/toddsqueen/html/wordpress/wp-includes/feed.php on line 417

    How can there be a Parse error in a php code that I did not alter at all? (/feed.php). I have only altered the wp-config.php file. What is wrong here? Thanks…

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi

    @esmi

    Forum Moderator

    Try re-uploading the wp-includes folder from a fresh download of WordPress.

    Darn…I already did that. I am using the latest version, 2.9.1. Anything else to try?

    Here is the line in feed.php it says has the syntax error:

    echo apply_filters(‘atom_enclosure’, ‘<link href=”‘%20.%20trim(htmlspecialchars($enclosure%5b0%5d))%20.%20′” rel=”enclosure” length=”‘ . trim($enclosure[1]) . ‘” type=”‘ . trim($enclosure[2]) . ‘” />’ . “\n”);

    Wow…I fixed it. Apparently GoLive changed href addresses if you drag files into the GoLive window. I didn’t know this…and it added some odd address based on the desktop folder I had unpacked the WordPress files in. I should have known this but didn’t. I need to switch to Dreamweaver…does anyone still use GoLive?? Thanks and sorry to take up the forum’s time…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] T_STRING error in feed.php’ is closed to new replies.