Support » Fixing WordPress » T_CONSTANT_ENCAPSED_STRING

  • I am in the process of migrating a site from a localhost to a liver server and am getting this message: Parse error: syntax error, unexpected ”);’ (T_CONSTANT_ENCAPSED_STRING) in /home/blakemor/public_html/wp-config.php on line 22.

    Here is my wp-config code – with the usernames etc XX’d. Suggestions will be most appreciated.

    <?php
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, and ABSPATH. You can find more information by visiting
     * {@link http://codex.wordpress.org/Editing_wp-config.php Editing wp-config.php}
     * Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', ‘xxx');
    
    /** MySQL database username */
    define('DB_USER', ‘xxx’);
    
    /** MySQL database password */
    define('DB_PASSWORD', ‘xxx’);
    
    /** MySQL hostname */
    define('DB_HOST', 'xxx');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    
    [removed keys]
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Justin Greer

    (@justingreerbbi)

    Forum Moderator

    I would be careful posting your sites connection information freely on the interwebs :).

    I just copied your code to a file and it looks like there is an encoding issue. Make sure that all the single quotes are actually ‘. It looks like there may be an error that occurs after copy and pasting.

    you have a backwards single quotes in your file it should be

    define('DB_NAME', 'xxx');
    
    /** MySQL database username */
    define('DB_USER', 'xxx');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'xxx');

    be sure to use simple text editor when modifying your files.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘T_CONSTANT_ENCAPSED_STRING’ is closed to new replies.