Support » Fixing WordPress » systematic image upload error

  • Resolved colombo79


    I’ve been trying to fix the already infamous WP 2.5 uploading “HTTP ERROR”.

    I’ve noticed quite a bunch of recent topics concerning this subject, none providing up to this date a specific and definitive fix.

    I’ve also followed the new “2.5 Image/Media Uploader problems” sticky list, there was some progress but the problem persists.

    Here’s how it went:

    1. Make sure you uploaded all the WordPress files correctly. Really, this is probably the most common upgrade problem.

    I’ve installed WP in a sub-domain in the corresponding http folder and everything was quickly (apparently) working. This is how it is installed.

    2. Clear your browser cache, restart your browser. Do it twice. Browser caches can be persistent little things.


    3. Update your Adobe Flash to the latest version (esp you Linux users!): Flash


    4. IE has specific known issues. Download these two files, replace them in your WordPress installation: IE-Fix

    What’s IE?? Is it like… A browser? “IE-Fix” sounds like a paradox ^^;

    5. Another known issue is where the media buttons don’t appear at all. This happens when you have an older plugin interfering with the JavaScript. I encountered this problem with an older version of WP-Amazon, but any plugin loading its own jQuery can cause the issue. Disable your plugins and see if the buttons appear. If so, reactivate one by one until they don’t appear any more. Upgrade all your plugins as well.

    Media buttons look fine.

    6. Bad Behavior breaks the uploader. Disable it. There have been reports that editing the “” file to remove the line containing “Shockwave Flash” also works.

    Bad what??

    7. mod_security might be causing problems. Disable it to see if that is the problem. To do this, make an .htaccess file in your wp-admin directory. Add this to it:
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    That will disable it for the entire wp-admin directory. It’s possible to be more specific about it, this is just a quick and easy test to see if mod_security is causing your issues.

    Done that. It only got me a “Fatal error” followed by a lot of text when trying to log into my wordpress. Removed it. Back to square zero.

    8. Worst case… Disable the flash uploader for now, using this plugin: No-Flash-Uploader”

    Before doing this, as suggested in other topics I manually created an “uploads” folder (755) inside “wp-content” folder, went to setting>miscellaneous>store uploads in this folder and updated field with


    . After doing this the progress bar in the image/media uploader started to move for the first time, only to get into the “crunching” status and give the same error.

    After that I installed and activated the referred plugin, only to get the new error message “The uploaded file could not be moved to /var/www/vhosts/ 118”

    Guys, if “CODE IS POETRY” please double check your rhymes before releasing your stuff… the “5 minutes wp installation” are more like 5 hours at the moment, and still not working.

Viewing 6 replies - 1 through 6 (of 6 total)
  • before you blame WordPress, keep in mind that the image uploader works for most users, and most of the time fails due to host issues.

    That said, try installing 2.5 on demo sites and see if the problem persists.


    I’m above all trying to provide some feedback.

    Since in just a couple of days I’ve found a bunch of topics (to the point a sticky was created…) concerning a specific problem with the new uploader and it is release-related, it’s fair to assume it’s a WP bug. A release should account for different types of servers, not the other way around. I’ve also read it can or cannot work in some browsers. Would you say it’s due to browser issues? No, it’s simply not fully browser-tested… 😉

    Anyway, thanks for the suggestion, it’s fixed:

    – updated flash
    – manually created “uploads” folder inside “wp-content” folder, went to setting>miscellaneous>store uploads in this folder and updated field with “wp-content/uploads”
    – changed new “wp-content/uploads” chmod

    awesome! glad you figured it out. sounds like it was a permissions problem.

    yea in the end i think it was that. dunno if browser cache clearing or flash update could have something to do with it too… perhaps. i could have just made a fresh installation of a previous release but i seem to enjoy banging my head in my keyboard a lot :O

    I have had simular problems with the viewer, Only I get the “fatal error” message in all the media tabs. I have tried it in Firefox, Safari, and Opera all with the same results. I have have spent Hours (and hours) going through this magic list of 8 and nothing corrects the baseline problem. I have noticed that the moderators are using the “topic closed” function a lot and then refering back to the magic 8 list.

    I am not without fault, but I have double checked my steps a dozen times and so have a lot of other people with the same problem.

    what chmod setting did you use for the uploads folder (just so I can check it on my own site?)



Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘systematic image upload error’ is closed to new replies.