Support » Installing WordPress » System Requirement to install WordPress

  • Hi, may I know what is the system requirement of the server to install WordPress?
    Windows? Linux?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    It’s generally suggested but not required that people use Linux. It just somehow works out better though many people do successfully use WordPress on Windows servers.

    Give this a read, it explains more what requirements you need to host a WordPress installation.

    https://wordpress.org/about/requirements/

    RoseHosting

    (@rosehosting)

    You will also need to have some PHP extensions installed/enabled like gd, mbstring, mcrypt, xml, mysql etc. Check this with your hosting provider, most likely they are already installed/enabled.

    • This reply was modified 9 months ago by  RoseHosting.
    serhaterkan

    (@serhaterkan)

    gct7

    (@gct7)

    Thanks all for the replies. Appreciated it.

    However, the link that doesn’t show the minimum requirement of the operating system, etc.
    May I know where can i find those information?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘System Requirement to install WordPress’ is closed to new replies.