WordPress.org

Support

Support » Plugins and Hacks » [Resolved] FTP SYST command causing job to abort

[Resolved] FTP SYST command causing job to abort

  • I get this error 3 times before the job gets aborted for too many attempts.

    [30-Dec-2013 16:28:40] FTP client command: SYST
    [30-Dec-2013 16:28:40] WARNING: ftp_systype(): Login incorrect.
    [30-Dec-2013 16:28:40] ERROR: FTP server reply: Error getting SYSTYPE
    [30-Dec-2013 16:28:40] WARNING: ftp_pwd(): Login incorrect.
    [30-Dec-2013 16:28:40] ERROR: FTP Folder “BackWPup” cannot be created!

    I can connect via an FTP client and sending the command SYST returns 215 UNIX Type: L8, so why am I getting a SYSTYPE error?

    http://wordpress.org/plugins/backwpup/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Forgot to mention it does successfully log in before this error.

    [30-Dec-2013 23:47:09] 1. Try to send backup file to an FTP server …
    [30-Dec-2013 23:47:09] Connected via explicit SSL-FTP to server: redacted.com:21
    [30-Dec-2013 23:47:09] FTP client command: USER redacted
    [30-Dec-2013 23:47:10] Undefined offset: 0
    [30-Dec-2013 23:47:10] FTP server reply:
    [30-Dec-2013 23:47:10] Undefined offset: 0
    [30-Dec-2013 23:47:10] FTP client command: PASS *******
    [30-Dec-2013 23:47:10] Undefined offset: 0
    [30-Dec-2013 23:47:10] FTP server reply:
    [30-Dec-2013 23:47:10] Undefined offset: 0
    [30-Dec-2013 23:47:10] FTP client command: SYST
    [30-Dec-2013 23:47:10] WARNING: ftp_systype(): Login incorrect.
    [30-Dec-2013 23:47:10] ERROR: FTP server reply: Error getting SYSTYPE
    [30-Dec-2013 23:47:10] ERROR: FTP Folder “BackWPup” cannot be created!
    [30-Dec-2013 23:47:10] 2. Try to send backup file to an FTP server …
    [30-Dec-2013 23:47:11] Connected via explicit SSL-FTP to server: redacted.com:21
    [30-Dec-2013 23:47:11] FTP client command: USER redacted
    [30-Dec-2013 23:47:12] Undefined offset: 0
    [30-Dec-2013 23:47:12] FTP server reply:
    [30-Dec-2013 23:47:12] Undefined offset: 0
    [30-Dec-2013 23:47:12] FTP client command: PASS *******
    [30-Dec-2013 23:47:12] Undefined offset: 0
    [30-Dec-2013 23:47:12] FTP server reply:
    [30-Dec-2013 23:47:12] Undefined offset: 0
    [30-Dec-2013 23:47:12] FTP client command: SYST
    [30-Dec-2013 23:47:12] WARNING: ftp_systype(): Login incorrect.
    [30-Dec-2013 23:47:12] ERROR: FTP server reply: Error getting SYSTYPE
    [30-Dec-2013 23:47:12] ERROR: FTP Folder “BackWPup” cannot be created!
    [30-Dec-2013 23:47:12] 3. Try to send backup file to an FTP server …
    [30-Dec-2013 23:47:12] Connected via explicit SSL-FTP to server: redacted.com:21
    [30-Dec-2013 23:47:12] FTP client command: USER redacted
    [30-Dec-2013 23:47:13] Undefined offset: 0
    [30-Dec-2013 23:47:13] FTP server reply:
    [30-Dec-2013 23:47:13] Undefined offset: 0
    [30-Dec-2013 23:47:13] FTP client command: PASS *******
    [30-Dec-2013 23:47:13] Undefined offset: 0
    [30-Dec-2013 23:47:13] FTP server reply:
    [30-Dec-2013 23:47:13] Undefined offset: 0
    [30-Dec-2013 23:47:13] FTP client command: SYST
    [30-Dec-2013 23:47:13] WARNING: ftp_systype(): Login incorrect.
    [30-Dec-2013 23:47:13] ERROR: FTP server reply: Error getting SYSTYPE
    [30-Dec-2013 23:47:13] ERROR: FTP Folder “BackWPup” cannot be created!
    [30-Dec-2013 23:47:13] ERROR: Step aborted: too many attempts!
    [30-Dec-2013 23:47:13] ERROR: Job has ended with errors in 11 seconds. You must resolve the errors for correct execution.

    I can see in my console on the FTP server that the user has logged in, but when it tries to send the backup, the console also registers invalid login. I can log in to the FTP server the same way with WinSCP and create the folder manually, but this plugin throws a fit.

    Found the problem. BackWPup does not support ASCII passwords. Changing to alphanumeric solved the login problem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] FTP SYST command causing job to abort’ is closed to new replies.