Support » Plugin: Jetpack by WordPress.com » SyntaxError: Unexpected token < in JSON at position 0

  • Resolved mwestrik

    (@mwestrik)


    Hi,

    I just installed wordpress for a new site and installed jetpack. When trying to activate any of jetpacks features, I do get this error:

    Recommended features failed to activate. SyntaxError: Unexpected token < in JSON at position 0

    Same error when manually trying to activate a single feature:
    Likes failed to activate. SyntaxError: Unexpected token < in JSON at position 0

    i already tried uninstalling jetpack and reinstalling it, the same error again.

    anybody any ideas?

Viewing 15 replies - 46 through 60 (of 69 total)
  • Solved completely with this tricky way:
    first of all you must disable WP REST API plugin then change your wordpress theme to another template.

    follow my last reply to this topic to completely resolve this issue.

    • This reply was modified 2 years, 10 months ago by  Mahdi Zolfaghari. Reason: solved completely

    @therealwesfoster – You were right. I did what you suggested, saved my permalinks again and worked like a charm. I wonder why no one bothers to read anymore…lol! Simple and easy solution…thanks a ton.

    Solved completely with this tricky way:
    first of all you must disable WP REST API plugin then change your wordpress theme to another template.

    This reply was modified 18 hours, 20 minutes ago by Mahdi Zolfaghari.

    @mahdizk‘s solution did not work in my case

    I had the same issue here: https://wordpress.org/support/topic/cannot-deactivate-related-post-or-photon/#post-8307727

    I didn’t get any errors because I only wanted to turn two things off in jetpack (related posts / photon) and it would say it was successfully but when I refreshed the page, it wasn’t turned off.

    Finally, I stumbled “turning on” something and it gave me the same error which google led me here.
    It was this plugin β€œJSON plugin WP REST API” causing the conflict. So I turned off that plugin and I changed my theme (but tip: turn off jetpack because it broke my site and had to manually delete jetpack from ftp)… NOW it finally works. Thanks @mahdizk

    Switching themes

    I still have the same problem with the last version 4.3.2

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    @danieljulia Could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post

    There, could you let me know what other plugins are currently active on your site?

    Thank you!

    @therealwesfoster Thank you so much buddy.

    I refreshed permalinks. It worked. πŸ™‚

    SyntaxError: Unexpected token < in JSON at position 0

    This error is coming while I try to pay through my bitcoin plugin.

    How to resolve it?

    Thank you

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    @jackman16 Do you see that error message in the Jetpack menu in your dashboard? Jetpack doesn’t include any built-in payment options, so if the error appears on another page of your site, your problem is most likely not linked to Jetpack. I’d recommend getting in touch with the Bitcoin plugin author to find out more.

    Hello,

    Same Issue With Me. I have watched the posts resolved on the subject, but none answers the problem so far.

    Anyone found the solution for this issue?

    Thanks!

    • This reply was modified 2 years, 8 months ago by  amritosh p.
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic πŸš€

    @amritosh-p Could you please start your own thread, as I suggested above, and tell me more about your site and the plugins you use there?
    https://wordpress.org/support/plugin/jetpack#new-post

    Thank you.

    I had the same problem. I installed on a test server and moved the site. I had Jetpack installed on the testserver, but not activated yet. After moving the site I activated Jetpack and got this problem. I went to the Permalink settings and after moving they had changed back to the standard settings. I saved the same settings as on my testserver and voila: Jetpack is working properly.

    Just wanted to share in case this solves it for someone else as well.

    Saving permalinks helped me too! Thank you!

    Hello, can I know how you managed to fix this issue ?

    Thanks.

Viewing 15 replies - 46 through 60 (of 69 total)
  • The topic ‘SyntaxError: Unexpected token < in JSON at position 0’ is closed to new replies.