Support » Plugin: Jetpack by WordPress.com » SyntaxError: Unexpected token < in JSON at position 0

  • Resolved mwestrik

    (@mwestrik)



    Hi,

    I just installed wordpress for a new site and installed jetpack. When trying to activate any of jetpacks features, I do get this error:

    Recommended features failed to activate. SyntaxError: Unexpected token < in JSON at position 0

    Same error when manually trying to activate a single feature:
    Likes failed to activate. SyntaxError: Unexpected token < in JSON at position 0

    i already tried uninstalling jetpack and reinstalling it, the same error again.

    anybody any ideas?

Viewing 15 replies - 16 through 30 (of 69 total)
  • same here with wordpress 4.6.1

    I did manage to get it working after some trouble. I deleted my htaccess file and created a new one and then it started working OK.

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you all try the following:

    1. Open the dashboard page.
    2. Open your browser console
    3. Click on the Network tab
    4. Refresh the page.
    5. If you see any lines in red inside the browser console, click on them. A new panel should appear on the right.
    6. Click on the “Response” tab in that new panel.
    7. Copy the message displayed there.
    8. Send it to us via this form.
    9. If no red lines appeared in the browser console, click on the “Console” tab of the browser console.
    10. Copy any errors displayed there, and send them to us via this form.

    Thank you!

    The requested URL /blog/wp-json/jetpack/v4/connection/url was not found on this server.
    The requested URL /blog/wp-json/jetpack/v4/plugins was not found on this server.
    The requested URL /blog/wp-json/jetpack/v4/module/stats/data was not found on this server.
    The requested URL /blog/wp-json/jetpack/v4/module/protect/data was not found on this server.
    The requested URL /blog/wp-json/jetpack/v4/module/akismet/data was not found on this server.
    The requested URL /blog/wp-json/jetpack/v4/updates/plugins was not found on this server.
    The requested URL /blog/wp-json/jetpack/v4/site was not found on this server.

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @edmundphuang Could you send us the errors via this form, so we have more details about your site?
    Contact Support

    Thanks!

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you all try the following:

    1. Open the dashboard page.
    2. Open your browser console
    3. Click on the Network tab
    4. Refresh the page.
    5. If you see any lines in red inside the browser console, click on them. A new panel should appear on the right.
    6. Click on the “Response” tab in that new panel.
    7. Copy the message displayed there.
    8. Send it to us via this form.
    9. If no red lines appeared in the browser console, click on the “Console” tab of the browser console.
    10. Copy any errors displayed there, and send them to us via this form.

    Thank you!

    Submitted

    Can you please use Jetpack’s Debugger module to send us some more information about your site?

    1) Go to the Jetpack page in your dashboard.
    2) Click on the Debug link appearing at the bottom of the page.
    3) Click the link that says “click here to contact Jetpack support.”
    4) Fill in the description box and your name and email address.
    5) Click the “Contact Support” button.

    Thanks!

    I was able to submit through the debug link. Should I send console output as well?

    Done! (Thank you!!!)

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I was able to submit through the debug link. Should I send console output as well?

    @mischkaffee We’ll let you know if we need more details in our first reply. Thanks a lot!

    i have the same problem, i already send the report. Thanks!

    I had the same problem. In my case I did a test by moving my WP site to another server for testing (with All In On Migration plugin). It worked perfectly fine. So I was down to server configuration issue.

    Looking closer I checked the root of my website and found there was no .htaccess file. I checked my permalink settings and re-saved the settings. Then I checked and there was still no .htaccess file.

    I tried a reinstall of WordPress was prompted for FTP info so this indicated WordPress doesn’t have access to change files in my WordPress Installation folder. I had to check that permissions were set correctly. For me that would be running in linux via ssh 1) cd /var/www 2) chown -R apache:apache html This is because my wordpress install is in /var/www/html. You would have to do it on your WordPress install folder.

    After setting permissions correctly go to the Permalink settings and click save to re-generate the .htaccess file. Then try turning on Jetpack features. For me this worked and now I’m living the life.

    On my new wordpress installation i had the same problem with Jetpack.
    After creating default .htaccess file in my root folder and refreshing the dashboard, everything is working.

    https://codex.wordpress.org/htaccess

    That is the solution, as @marcelg7 wrote in the previous post.

    on my new wordpress installaation i have this error to

    Manage failed to activate. SyntaxError: Unexpected token < in JSON at position 0

    this is work for me, thnks

Viewing 15 replies - 16 through 30 (of 69 total)
  • The topic ‘SyntaxError: Unexpected token < in JSON at position 0’ is closed to new replies.