Support » Plugin: Remote Content Shortcode » SyntaxError: Unexpected token }

  • Resolved MrRusch

    (@mrrusch)


    I am trying to fetch a single JSON data value from a nginx server which redirects requests to an underlying z-way-server, both running on a Raspberry Pi. Might not be your typical usage scenario, but possibly the most basic content-wise.

    When using the shortcode without the userpwd option I get an authentication error as expected. When adding this threw a site option I am left with the following response “SyntaxError: Unexpected token }”.

    Any idea of what this could be about? Sounds like some parsing is going wrong but there really shouldn’t be much to parse – the response is just an integer. Any way to enable some more debug logging?

    https://wordpress.org/plugins/remote-content-shortcode/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author doublesharp

    (@doublesharp)

    @mrrusch Where did you see that error? Was it printed directly onto the page? Is there anything in your error log?

    Thanks!

    Plugin Author doublesharp

    (@doublesharp)

    Can you include the full shorttag you are using – you can omit the real URL. I want to get an idea of what parts of the code might be executing and causing the issue.

    MrRusch

    (@mrrusch)

    Sorry, I worked it out by manually creating the XMLHTTPRequest without the plugin. You can delete this thread – thank you for quick answer anyway!

    Plugin Author doublesharp

    (@doublesharp)

    No problem, if I get a chance I will do more testing with JSON results instead of HTML.

    J

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘SyntaxError: Unexpected token }’ is closed to new replies.