Support » Plugin: WP-Live Chat by 3CX » SyntaxError: Unexpected identifier ‘anti_cache’

  • Resolved devinc42

    (@devinc42)


    WPLC breaks javascript and I get the error message: SyntaxError: Unexpected identifier ‘anti_cache’. I only noticed it in Safari. Seems to be a problem using the let keyword. On line 425 of wplc_server.js changing “let anti_cache = Date.now();” to “var anti_cache = Date.now();” seems to fix it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi there,

    Thank you for getting in touch with us and reporting this.

    That’s strange because the latest version of Safari supports let variable. We’ll test it and fix in the next plugin version.

    Thank you for your time in this.

    Best regards,
    Jarek

    Yep, I guess I should update my Safari then (I rarely use it), I was using version 9.1.2 and let is only since Safari 10.

    Thank you for checking this. Please update browser and this should fix the issue.

    Kind regards

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘SyntaxError: Unexpected identifier ‘anti_cache’’ is closed to new replies.