Support » Plugin: Custom Field Bulk Editor » Syntax for updating simple relationship field (custom defined list)

  • Resolved ksymer

    (@ksymer)


    I installed Custom Field Bulk Editor so I can update a field value across all posts on a custom content type (created in Pods).

    I have a custom field [fund_type], a simple relationship (custom defined list). My list has only two choices in value|label format:

    annual|Annual scholarship
    endowed|Permanently endowed scholarship

    Note that the values are currently unpopulated because the field was created after the posts.

    I’ve attempted a variety of methods to populate the field. Each time it says success. And each time it does nothing to the value of the field across whatever posts I’ve selected.

    Could it be a simple syntax issue? I don’t see documentation on the exact way to enter both the field name and the string values.

    I’ve tried so many combinations of things with and without quotes on strings:

    
    //equations are shorthand to represent how I've entered the text in the Custom field name and Value fields on the bulk edit fields page:
    fund_type = annual
    fund_type = 'annual'
    fund_type = "annual"
    fund_type.meta_value = annual
    fund_type.meta_value = "Annual scholarship"
    etc...
    etc...
    etc...
    

    Is this feature supported? Please advise. Thank you!

Viewing 1 replies (of 1 total)
  • Of course, it suddenly works great moments after posting the topic. 🙂

    Documenting the syntax for others:

    In the Custom field name field, enter the lowercase field name.
    In the Value field, enter the relationship value string without quotes.

    For my scenario, I ran two updates, selecting different batches:

    fund_type = annual
    fund_type = endowed
    • This reply was modified 4 months, 4 weeks ago by  ksymer. Reason: code format
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.