WordPress.org

Forums

WordPress SEO by Yoast
Syntax error when updating WordPress SEO plugin today (12 posts)

  1. joycegrace
    Member
    Posted 1 year ago #

    Hello, I just used the WordPress updater to update the WordPress SEO plugin and now my site won't show because of a Syntax error: http://d.pr/i/aHTk

    Can you tell me how to fix this, or if a new release will patch this up?

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Rajesh Namase
    Member
    Posted 1 year ago #

  3. MacGuy42
    Member
    Posted 1 year ago #

    Same for me as well. I have it disabled.

  4. li9ssb
    Member
    Posted 1 year ago #

    The bug in :
    /public_html/wp-content/plugins/wordpress-seo/wp-seo.php
    See error log

  5. Alain Schlesser
    Member
    Posted 1 year ago #

    The cause seems to be an old version of php (< 5.3), which is essentially deprecated.
    You should verify with your hosting provider to update to supported version of php.

    If, like me, you use HostGator, here's how to change to a supported version:
    http://support.hostgator.com/articles/hosting-guide/hardware-software/php-5-3

  6. DoctorMicro
    Member
    Posted 1 year ago #

    Host running 5.3.24, What is needed for this plugin???

  7. Husbarn
    Member
    Posted 1 year ago #

    Hey Alain i did like you said and it's working, i'm just curious if it's good to add value in .htaccess file like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # Use PHP 5.3
    AddType application/x-httpd-php53 .php

    # END WordPress

    Or should i add it outside this code?

    # BEGIN WordPress
    # END WordPress

    ABove # BEGIN WordPress there is a huge code from yoast seo plugin.

  8. Giampietro Pregnolato
    Member
    Posted 1 year ago #

    same problem here!

  9. mikeotgaar
    Member
    Posted 1 year ago #

    @Husbarn
    No problem using .htaccess this way

    Just make sure the following is in your .htaccess file - it should be at the top, just after - RewriteEngine On

    # Protect the htaccess file
    <Files .htaccess>
    Order Allow,Deny
    Deny from all
    </Files>

    This should be in every .htaccess file!

    And chmod - or use CPanel/Hosting file manager to set the file permissions to 644 or stronger...

  10. joycegrace
    Member
    Posted 1 year ago #

    It appears the update to WordPress SEO resolves the Syntax error now, with or without switching to Php 5.3

  11. lpblue
    Member
    Posted 1 year ago #

    I just did a new install of the Yoast plugin and had the same results with

    Fatal error: Call to undefined method WP_Query::is_main_query() in ...wp-content/plugins/wordpress-seo/frontend/class-frontend.php on line 474.

    I've used it with no problem on other sites. What's the solution?

  12. lpblue
    Member
    Posted 1 year ago #

    Update! I installed v 1.4.10 today, and apparently needed to upgrade WordPress to 3.5.1, which I did and now I am not getting the fatal error any more. The upgrade went fine and I reactivated the Yoast plugin and that went fine - BUT none of the plugin fields show up in the dashboard. I have the Yoast menu in the left column and I see the settings, but in the pages and posts themselves there are no fields under where it says "WordPress SEO by Yoast." There is just that title with a down arrow to the right of it, but no expanding box or fields or anything.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress SEO by Yoast
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic