Support » Plugin: HTTP Headers » Syntax error, unexpected ‘(‘ in /public_html/.user.ini on line 6

  • Resolved KVNHNF

    (@kvnhnf)


    Hello,

    Siteground error logs shows numerous lines with the following:

    2020-06-28 04:41:37 UTC [apache][:error] [pid xxxxx] [client xxx] PHP: syntax error, unexpected ‘(‘ in /public_html/.user.ini on line 6, referrer: xxx

    This is caused by the following:

    # BEGIN HttpHeadersCookieSecurity
    # The directives (lines) between BEGIN HttpHeadersCookieSecurity and END HttpHeadersCookieSecurity are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    # END HttpHeadersCookieSecurity

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter KVNHNF

    (@kvnhnf)

    Is there any way to fix this? Thanks

    Plugin Author Dimitar Ivanov

    (@zinoui)

    The error seems strange to me, because the plugin store only the following settings into the .user.ini file:

    session.cookie_httponly = on
    session.cookie_secure = on
    session.cookie_samesite = "Lax"

    I mean there are no any “(” symbols.

    Can you post the content (along the error) of your .user.ini file here please?

    Thread Starter KVNHNF

    (@kvnhnf)

    Hi Dimitar, thank you for your swift reply

    Isn’t it the very commenting there wich has “(lines)” that creates the error?

    Here is the content of my user.ini file:

    ; Wordfence WAF
    auto_prepend_file = ‘/home/customer/www/finelovedolls.com/public_html/wordfence-waf.php’
    ; END Wordfence WAF

    # BEGIN HttpHeadersCookieSecurity
    # The directives (lines) between BEGIN HttpHeadersCookieSecurity and END HttpHeadersCookieSecurity are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    # END HttpHeadersCookieSecurity

    Thanks

    Best regards

    Plugin Author Dimitar Ivanov

    (@zinoui)

    Oh, now I see.
    I’ll try to fix it as soon as possible.

    Thread Starter KVNHNF

    (@kvnhnf)

    ok thank you

    Thread Starter KVNHNF

    (@kvnhnf)

    hey just a quick reminder regarding the above, thanks

    Thread Starter KVNHNF

    (@kvnhnf)

    Hi Dimitar, can you tell me how to fix it until the update? thanks

    Plugin Author Dimitar Ivanov

    (@zinoui)

    Hi @kvnhnf

    I just released a new version (1.15.2) who fix this bug.

    Note that If your .user.ini file still contains # BEGIN…, # END…, or any other comments that starts with # symbol, you need to remove them manually (or replace the # with ; symbol).

    After updating the plugin, go to the Cookie Security page and save your settings again.

    Thread Starter KVNHNF

    (@kvnhnf)

    Hi Dimitar, sorry for my late reply

    Updated the plugin, but the error keeps on showing.

    Haven’t enabled cookie security header so far, and did as you asked (saved it again with it being set to “off”)

    Also manually deleted this part from user.ini file:

    # BEGIN HttpHeadersCookieSecurity
    # The directives (lines) between BEGIN HttpHeadersCookieSecurity and END HttpHeadersCookieSecurity are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    # END HttpHeadersCookieSecurity

    Hopefully that did the trick

    Best regards

    Anika

    (@nepalionlinepasal)

    Hi, i still get this issue on line 3 and my user.ini looks like below

    # BEGIN HttpHeadersCookieSecurity
    # The directives (lines) between BEGIN HttpHeadersCookieSecurity and END HttpHeadersCookieSecurity are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    # END HttpHeadersCookieSecurity

    shall i replace with below?

    ; BEGIN HttpHeadersCookieSecurity
    ; The directives (lines) between BEGIN HttpHeadersCookieSecurity and END HttpHeadersCookieSecurity are
    ; dynamically generated, and should only be modified via WordPress filters.
    ; Any changes to the directives between these markers will be overwritten.
    ; END HttpHeadersCookieSecurity

    Plugin Author Dimitar Ivanov

    (@zinoui)

    Hi Anika

    Actually, since v1.18.0 the plugin don’t use .user.ini to store cookie security settings.

    So, it’s absolutely safe to remove all those lines enclosed in # BEGIN/END HttpHeadersCookieSecurity comments.

    Then go to Cookie Security page and save again your settings.

    Anika

    (@nepalionlinepasal)

    Hi Dimitar, Thank you for response.

    • This reply was modified 6 months, 3 weeks ago by Anika.
Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Syntax error, unexpected ‘(‘ in /public_html/.user.ini on line 6’ is closed to new replies.