Support » Theme: Lovecraft » Syntax error on comments.php:149

  • Resolved Kadai Crosshansen

    (@kadaicross)


    In the latest version (1.22) there is an Syntax error thrown at line 149 of comments.php.

    The whole error I get is like this:
    PHP Parse error: syntax error, unexpected ‘)’ in /home/—/public_html/wp-content/themes/lovecraft/comments.php on line 149

    I am trying to figure out the exact source of the error, as the mentioned line contains “), ),” and seems to be valid with the array and apply_filters that opened them.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thread Starter Kadai Crosshansen

    (@kadaicross)

    Continuation:

    I believed first that this may have been caused by the child theme customizations I have done to your theme, but it is not.

    Tried it on a test install I have and the same error appeared there. With a unmodified version of the lovecraft theme. Still can’t figure out what is wrong exactly.

    Thread Starter Kadai Crosshansen

    (@kadaicross)

    Look here: https://themes.trac.wordpress.org/changeset?old_path=%2Flovecraft%2F1.21%2Fcomments.php&old=86930&new_path=%2Flovecraft%2F1.22%2Fcomments.php&new=91741&sfp_email=&sfph_mail=

    On lines 139-140 (past version) and lines 148-149. Apparently the version of PHP I am using on a server (PHP 7.0.28) just complained at the way the parentheses and colon where written there.

    Needed to revert the closing parentheses as how it is on the lines 139-140 to make the script run without issues.

    What about a simple user as I am? What shall I do so I can use the update with no problems?
    Thank you!

    Theme Author Anders Norén

    (@anlino)

    I’m out right now, but I’ll have a fix for the notice within the next couple of hours. You can hold off from updating until then.

    Thank you! I can update in a couple of days or so. I am not in a hurry. As the previous version I could not use it because of an error…

    Thread Starter Kadai Crosshansen

    (@kadaicross)

    @andreeaw: better to wait for the next version (1.23) before update. As I am unsure if this might happen on any other environment (This was present on the version of PHP I use, but maybe not in the one that the developer has)

    So, is better to have a word from Anders about this before updating (specially if the website its important or production one)

    EDIT: Nevermind, there is the answer. Thank you Anders.

    No, it is just a blog, but with the previous version my pages dissapeared or something, i don’t remember exactly now, i said it at that time, so I am still using the 1.20 version.
    Being a blog though, I am part of a project where a group of bloggers publish theire reviews in the same time… I am not in a hurry with updating. I thought just that will be nice to be updated and working.

    Theme Author Anders Norén

    (@anlino)

    Hi @kadaicross and @andreeaw,

    The fix has been submitted now. It should be live in a couple of minutes.

    — Anders

    Thank you!

    Thread Starter Kadai Crosshansen

    (@kadaicross)

    I confirm this is working as expected now.

    Thanks for the fix.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Syntax error on comments.php:149’ is closed to new replies.