WordPress.org

Forums

PHP/MySQL CPU performance statistics
syntax error :( (13 posts)

  1. Sam_a
    Member
    Posted 11 months ago #

    Parse error: syntax error, unexpected $end in wp-content\plugins\mywebtonet-performancestats\mywebtonet-performancestats.php on line 673

    https://wordpress.org/plugins/mywebtonet-performancestats/

  2. Ihor Vorotnov
    Member
    Posted 9 months ago #

    2 months passed... I've got similar error after installing:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected end of file in /var/www/playground.paspar2.com/httpdocs/content/plugins/mywebtonet-performancestats/mywebtonet-performancestats.php on line 673

  3. mywebtonet
    Member
    Plugin Author

    Posted 8 months ago #

    Hi

    It might be because there is a newline missing on the last line. It should work without. If you delete the plugin and fetch it again, we have added a newline to line 673, if you get back to us we know if it works.

    Rgds

  4. LeoKesler
    Member
    Posted 8 months ago #

    I have the same error, but mine is in line 681 .
    Using latest version.

  5. mywebtonet
    Member
    Plugin Author

    Posted 8 months ago #

    Hi

    We have tested this plugin on numerous machines and are getting positive feedback from a lot of users so it is a bit weird that some can't get it to work.

    Can we ask you to remove the plugin and the install a fresh copy via the plugin manager, just did a minor change that might correct the error but need your feedback.

    Rgds

  6. mywebtonet
    Member
    Plugin Author

    Posted 8 months ago #

    Hi

    We have tested this plugin on numerous machines and are getting positive feedback from a lot of users so it is a bit weird that some can't get it to work.

    Can we ask you to remove the plugin and the install a fresh copy via the plugin manager, just did a minor change that might correct the error but need your feedback.

    Rgds

  7. LeoKesler
    Member
    Posted 8 months ago #

    Same error but now in line 680.
    My VPS server:
    nginx 1.4.x
    memcached
    maria-db
    PHP 5.5.9-1ubuntu4.3

  8. mywebtonet
    Member
    Plugin Author

    Posted 8 months ago #

    Hi

    Thats very difficult to say, we know that it works with all versions of PHP, wonder if the 5.5.9 might have a bug in it. It is tested here with PHP 5.5.15 (and previous versions back to 5.5.11)

    It's a very simple PHP script and should not give an error at all, reason why it moved up a number from line 681 to 680, is that we removed the ?> from the last line.

    If you can post the errormessage (the complete message) here, it might help us locate the problem.

    Rgds

  9. mywebtonet
    Member
    Plugin Author

    Posted 8 months ago #

    Hi

    You can try to edit the PHP script in line 1, change

    <?php
    to
    <?

    and see if it helps.

    Rgds

  10. LeoKesler
    Member
    Posted 8 months ago #

    Changing the <?php to <? only give some html text and corrupted the site. After I disabled the plugin, all back to normal.

    The new error was:
    Este plugin gerou 37063 caracteres de saída inesperada durante a ativação. Se encontrar mensagens de “headers already sent” problemas com feeds ou outros, tente desativar ou remover o plugin.

    The original error was:

    Parse error: syntax error, unexpected end of file in XXXXXXXXX/wp-content/plugins/mywebtonet-performancestats/mywebtonet-performancestats.php on line 680

  11. mywebtonet
    Member
    Plugin Author

    Posted 8 months ago #

    Hi

    Just did some minor changes to the code, if you try now (delete plugin and fetch from repository), it might work. If not, it must be some kind of incompatibilities between nginx and PHP, but give it a try!

    Rgds

  12. LeoKesler
    Member
    Posted 8 months ago #

    It's working !
    And I already submitted a result, to test if its really working.

  13. mywebtonet
    Member
    Plugin Author

    Posted 8 months ago #

    Hi

    It turns out that your webserver explicitly require

    <?php

    instead of just

    <?

    for enabling PHP in the code. It's not very common anymore, we have changed the code now and updated the version to 1.1.6 so everybody else can benefit from it :-)

    We appreciate your help :-)

    Rgds

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.