Support » Plugin: WP Shopify » Syncing stuck in an infinite ajax loop at 99%

  • Resolved ahmar2

    (@ahmar2)


    Hi,
    I am using v.2.1.4 with sync settings set to manual posts. Whenever I try to sync the data it either goes to 100% or 99% but instead of finishing it gets stuck there. The timer keeps on running but it never finishes.

    When I check the inspect element and go to networks tab I can see a new ajax request getting generated after every 2 seconds. The request has these headers:

    HTTP/2.0 200 OK
    server: nginx/1.17.5
    date: Sun, 15 Dec 2019 12:53:37 GMT
    content-type: application/json; charset=UTF-8
    x-robots-tag: noindex
    link: <https://hidden/wp-json/>; rel="https://api.w.org/"
    x-content-type-options: nosniff
    access-control-expose-headers: X-WP-Total, X-WP-TotalPages
    access-control-allow-headers: Authorization, Content-Type
    expires: Wed, 11 Jan 1984 05:00:00 GMT
    cache-control: no-cache, must-revalidate, max-age=0
    x-wp-nonce: hidden
    allow: GET
    content-encoding: gzip
    vary: Accept-Encoding
    x-proxy-cache: DISABLED
    X-Firefox-Spdy: h2

    And the response for each and every request is :

    {"JSON":{"is_syncing":true,"syncing_totals":{"shop":1,"smart_collections":0,"custom_collections":58,"products":54888,"collects":304},
    
    "syncing_current_amounts":{"shop":1,"smart_collections":0,"custom_collections":58,"products":54592,"collects":304},"has_fatal_errors":false},"Response payload":{"EDITOR_CONFIG":{"text":"{\"is_syncing\":true,\"syncing_totals\":{\"shop\":1,\"smart_collections\":0,\"custom_collections\":58,\"products\":54888,\"collects\":304},\"syncing_current_amounts\":{\"shop\":1,\"smart_collections\":0,\"custom_collections\":58,\"products\":54592,\"collects\":304},\"has_fatal_errors\":false}","mode":"application/json"}}}

    I have no idea why it says Products 54592. Each and every request has same headers and same responses. See screenshot:

    https://photos.app.goo.gl/izs724cFJ81pVxEY7

    Can you please
    A. Guide me what could be the issue and how i can make it finish.
    B. Can this be the reason for webhooks not working. (See my other thread that I just created)

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Andrew – wpshop.io

    (@andrewmrobbins)

    @ahmar2

    Hey there, thanks for the questions.

    A. Try going into the plugin settings and adjusting the Items per request to 25. Also turn on Synchronous requests. Once these are changed, go into the Tools tab and perform a manual resync.

    B. Yeah, if the syncing doesn’t finish then the webhooks won’t connect. However, you can connect them manually by going into the Tools tab and using the Reconnect Automatic Post Syncing button. Make sure that you have the Enable auto post syncing setting enabled within the Syncing sub nav before doing this.

    Let me know if this helps!

    Plugin Author Andrew – wpshop.io

    (@andrewmrobbins)

    Closing. Feel free to re-open if you need.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.