• The plugin works fine, but the syncing is too slow. It takes 3 to 4 weeks while many other background processes are disturbed. Even simple analytics of Woo orders are delayed.

    Reached out to support 4 times, same answer, this is normal behaviour.

    After 4 weeks, the store syncing got stuck. I disconnected with the checkbox “keep data”.

    All data was lost, and the syncing process has to be restarted again. Support has been poor. Not that there was no communication, but there was no solution.

    And the issues persisted. So, I now downgraded my review to one single start.

    • This topic was modified 1 month, 4 weeks ago by marmasdelft.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Jordan Rich


    @marmasdelft We would like to take a closer look at your store to see if we can provide some insight. We understand the importance of syncing working in a timely manner. However, there are many variables between WordPress and WooCommerce and the server environment in which the site is hosting that could be affecting the syncing behavior.

    Help us investigate further by providing the following:

    • Store URL
    • Confirm if Support is Enabled under the Advanced settings in the Mailchimp Plugin.

    Once we have that information we’ll check our systems to see if we can get a hint on what may be causing the slowdown.

    Thread Starter marmasdelft


    Mailchimp support case 12455131

    Support is enabled!

    Plugin Support Jordan Rich


    Thanks for the information we’ve reached out to our colleagues in Mailchimp support for the support ticket information and thread. However, until we receive that information, I went ahead and did an investigation on the store in question.

    Taking a look at this store, I was able to see that there are reoccurring Fatal Errors that stem from a PHP limit error: 

    allowed memory size of 536870912 bytes exhausted (tried to allocate 1662322512 bytes) context: {"error":{"type":1,"file":"\/home\/vist3191\/cme-pro.com\/wp-content\/plugins\/debug-log-config-tool\/app\/controllers\/logcontroller.php","line":245},"backtrace":[{"file":"\/home\/vist3191\/cme-pro.com\/wp-content\/plugins\/woocommerce\/includes\/class-woocommerce.php","line":378,"function":"critical","class":"wc_logger","type":"->"},{"function":"log_errors","class":"woocommerce","type":"->"}]}

    This in turn can be causing a bottleneck which results in a degradation in performance of the site and the WooCommerce Action Schedular in which Mailchimp uses to sync data. 

    Here’s what it means in the context of WordPress and WooCommerce:

    The error occurred in the LogController.php file of the “Debug Log Config Tool” plugin on line 245.

    The WooCommerce class (class-woocommerce.php) was trying to log an error on line 378, but this operation required more memory than was available to PHP.

    PHP has a memory limit setting that restricts how much memory a script can use. In this case, the limit was set to 536870912 bytes (512MB), but the script tried to allocate 1662322512 bytes (around 1.5GB) of memory, exceeding the limit.

    To resolve this issue, you can try the following steps:

    1. Increase the PHP memory limit by adding the following line to your WordPress site’s wp-config.php file: define(‘WP_MEMORY_LIMIT’, ‘1024M’); This will increase the memory limit to 1GB, which should be sufficient for most cases.
    2. Deactivate and remove the “Debug Log Config Tool” plugin, as it seems to be the source of the memory exhaustion issue in this case.
    3. Check for any other memory-intensive plugins (besides Woocommerce and Mailchimp) or operations on your site and try to optimize or disable them if possible.
    4. Finally once all above steps are completed, try kicking the sync into flowing by checking for pending Scheduled Actions under WooCommerce > Status > Scheduled Actions > Pending. And click Run next to an Mailchimp WooCommerce Hooks.

    It’s important to note that increasing the memory limit is a temporary solution, and it’s better to identify and fix the root cause of the excessive memory usage to prevent similar issues in the future. These memory issues aren’t being caused by Mailchimp in particular, but a combination of things that are outside the scope of our support we can provide without direct access to your server and hosting environment. 

    Once these mentioned server environment issues have been address it should help Mailchimp sync with a better performance.

    Plugin Support Jordan Rich



    Apologies, I was made aware that WordPress does not allow for us to provide support in the review section. Would you mind bringing any further questions in to the Support Forum here: https://wordpress.org/support/plugin/mailchimp-for-woocommerce/


    Thread Starter marmasdelft


    I deactivated Debug Log Config Tool and did a run on the webhook for Mailchimp. It now seems the syncing process has been terminated on the Woo side, while it is still being executed at the Mailchimp side.

    Does that mean I have to start all over?

    Plugin Support Jordan Rich


    @marmasdelft We’ve since gained control over the Support request made in Mailchimp and will be following up our correspondence with you there.

    In this version of the plugin the resync button has been removed. This is a big problem because although it appears that it has been synchronized every day, that is a lie, and the WooCommerce images of the products are not seen or loaded in MailChimp when you create an email… That is, now we cannot send promotional emails…

    Plugin Support khungate


    Hi @comprarkefir, thanks for your comment. The best way to reach us for support is over at the GitHub plugin page: https://github.com/mailchimp/mc-woocommerce/. From there, you can receive direct responses from the development team, log new issues, download the latest version, and track existing support tickets. We’re happy to troubleshoot further as this should not be impacting what you’re describing; it sounds like something else is in play.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this review.