[resolved] "%" symbol breaks wordpress 3.5 (7 posts)

  1. SRhoney
    Posted 2 years ago #

    When the percent symbol is not present in any fields I'm able to update the database. When the percent symbol is included in a text field or text area it chokes.

  2. BeautyPirate
    Posted 2 years ago #

    Have you ever used a plugin called Bullet Proof Security? Or do you by any chance still use it? There are known issues with WP 3.5 and that plugin so do two things:

    - Upgrade that plugin to it´s most recent version!

    If you don´t use it anymore then this down here might help as well.

    You should know that the htaccess file placed by that plugin REMAINS active when it is deleted. This is okay but you don´t get the updates anymore. Here´s what I did:

    - I don´t use the BPS plugin anymore as I find it is unnecessary bloated. But I do use their secure htaccess file in a modified version. (By the way, I do donate 20$ to every plugin that shows a link to a donation page.) Anyway... Download the plugin to your desktop and extract the secure htaccess file... See the code is looking very different than the one from your old version? This needs to be updated piece by piece or if you do not have ANY other htaccess rules added you may copy the file entirely but always keep a backup of the old file.

    The reason being is first, it is important to keep it up to date and secondly the plugin has features that strip out special characters from certain GET or POST request on the server. This is to prevent malicious code injections and is in fact really helpful when being frequently updated.

    However this might NOT help you with your issue right now but then you at least did not waste any time as this should be done ANYWAY.

  3. SRhoney
    Posted 2 years ago #

    Clean install of WP 3.5., it's not working out of the box.

  4. Which "box"? Specifically, which hosting service?

    Because what you are describing with regards to it "choking" on a specific character tends to indicate that your hosting service is somehow blocking something based on some security rules or some such similar thing.

    WordPress works fine with percent-signs, so something somewhere else is causing the problem.

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    I'm able to update the database

    Please describe exactly what you are doing.

  6. SRhoney
    Posted 2 years ago #


    when I edit a page, post, or css file and include the "%" symbol any of the form fields and then click update. I get the following error.

    Not Acceptable
    An appropriate representation of the requested resource {path to wordpress file} could not be found on this server.

  7. SRhoney
    Posted 2 years ago #

    @Samuel Wood

    --Thanks, your advice worked.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.